Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I use PPPOE to connect to Internet and enable network discovery for public networks, do I open my shared folders to others? If only admin from ISP can see my folders i dont't like it :) I hate this, but I can't make my UnIndentified LAN connection as Home network because of strange Windows 7 limitations or my ignorance?

Edit This question should be on serverfault ;( This link can help to understand why I ask this question. I will update if any of solutions there work for me.

share|improve this question

Generally speaking, you should be connected to the internet service provider via a router or modem, not directly from your computer, unless you are using an old modem or one of a small few other devices.

If you go in to network and sharing centre, even if you can not change the location of the network, you should be able to manually disable file and print sharing.

I would highly advise you do this as it is really not a good idea to have this visible across the Internet, unless your ISP uses NAT or another method for sharing, this could be a big security risk.

share|improve this answer
I am out at the moment, if you need any further help or want pictures, let me know and I will try to do it when I get back tonight. – William Hilsum Nov 29 '10 at 16:43
I know that I can disable sharing, but I want to share data on my LAN. I don't know if ISP uses something for security on his point for my PPPOE, how can I find out that? – watbywbarif Nov 30 '10 at 11:38
What protocols are used for network discovery and sharing? Maybe this is below PPPOE? I could study this for hours to learn more, but if someone knows this it will save me time ;) – watbywbarif Nov 30 '10 at 11:42
@watbywbarif I don't know what you mean by below - PPPOE is a method of connecting two networks - Network discovery works on top of that after a connection has been established. If your ISP is just an ordinary (non blocking) isp, you will have unrestricted access to the internet, and others will have access to your machine... Click on "Advanced Sharing Settings" in "Network and Sharing Center" and you should be able to disable sharing on everything other than home/work networks. – William Hilsum Nov 30 '10 at 12:37
Heh, this is the problem, windows treats my LAN as unidentified so option to change its network type is greyed out. It is public, so I wanted to allow sharing for public networks to surpass this, but this will possibly make hole in my security. It seems that Windows 7 needs to have gateway in network to Identify network. I tried to put 2 computers in network to be each-others gateways, and this works but i have to disable-enable network for computer that boots first :D – watbywbarif Nov 30 '10 at 14:42

One connects to the Internet via a router. The router creates a local network inside your home, and serves as a one-way door to the greater network which is the Internet. Your local computers are not on the Internet - it is the router that is on the Internet. There is no way for the ISP to use the router to access your local network and its shares. The router only allows inside-to-outside connections, and in any case the local computers have no Internet address and so are not visible on it.

Therefore, setting the local network to private is fine, since only computers on the local network can see it. You should, however, protect yourself from your neighbors, who can see your router, by taking some elementary steps which your ISP should have described.

If you use a modem rather than a router to connect to the Internet, the situation is quite different. In this case, you should protect yourself by turning off File and Printer Sharing (in Properties of network adapter).

You may also be able to Change the default profile for unidentified networks through the registry :

In regedit find :
and look for your NIC adapter and create a dword named *NdisDeviceType and modify the value from 0 to 1, then disable/enable the network adapter.

You also might try this :

  1. In regedit, locate and then click the following registry subkey:
    Click the (GUID) subkey that corresponds to the network adapter.
  2. On the Edit menu, select New, and then DWORD (32-bit) Value.
  3. Rename it as DhcpConnEnableBcastFlagToggle, and press ENTER.
  4. Right-click DhcpConnEnableBcastFlagToggle, and then click Modify.
  5. In the Value data box, type 1 and click OK.
  6. Close Registry Editor.
share|improve this answer
You based you response on assumption that router starts PPPOE connection to ISP. Here is case that I connect to ISP and initiate PPPOE connection directly from my PC. Hence if I allow sharing for public networks my shared documents can possibly be visible to other users on Internet, maybe the ones that are on same subnet on my ISP? – watbywbarif Dec 1 '10 at 13:39
I have added some more stuff you could try. – harrymc Dec 1 '10 at 15:03
*NdisDeviceType will just ignore device when trying to Identify networks and not show it Network Center – watbywbarif Dec 3 '10 at 22:13
DhcpConnEnableBcastFlagToggle has something to do with networks with DHCP server, which is not my case, so I can not see how it can help? – watbywbarif Dec 3 '10 at 22:14
This hack is mentioned in several places for tricking Windows into thinking that an unknown network is of type NDIS. It may no longer pertain to Windows 7, but is worth trying. Although it does look like black magic. – harrymc Dec 4 '10 at 8:10
up vote 1 down vote accepted

Because answer is written in comments: I went looking into protocols enabled for PPPOE connection (only ipv4 and ipv6). Because protocols 'Client for Microsoft networks' and 'File and printer sharing for Microsoft networks' are not enabled for PPPOE i assume that it is no security risk to enable Network discovery for public networks in my case.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .