Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Mac OS X 10.6, and the problem appeared after the latest update.

Chrome and Safari can browse the Internet fine, but I can't ping google.com or apple.com. I have also found that bzr fails, but git works for some reason.

I thought it might be an IPv6 issue, so I tried disabling IPv6 on all the interfaces I could, but the problem continued.

I have no idea what might be causing this. Thanks for any help you can give!

Edit:

ifconfig produces

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:25:00:a9:93:9e 
    inet6 fe80::225:ff:fea9:939e%en0 prefixlen 64 scopeid 0x4 
    inet 165.82.76.128 netmask 0xffffff00 broadcast 165.82.76.255
    media: autoselect (100baseTX <full-duplex>)
    status: active
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 00:25:00:ff:fe:a9:93:9e 
    media: autoselect <full-duplex>
    status: inactive
en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:24:36:af:45:d4 
    media: autoselect (<unknown type>)
    status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    ether 00:1c:42:00:00:08 
    inet6 fe80::21c:42ff:fe00:8%en2 prefixlen 64 scopeid 0x7 
    inet 10.211.55.2 netmask 0xffffff00 broadcast 10.211.55.255
    media: autoselect
    status: active
en3: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    ether 00:1c:42:00:00:09 
    inet6 fe80::21c:42ff:fe00:9%en3 prefixlen 64 scopeid 0x8 
    inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
    media: autoselect
    status: active

And ipfw list produces

65535 allow ip from any to any
share|improve this question
3  
Do you have an outgoing firewall installed? If so check it's not blocking these commands. –  ChrisF Nov 29 '10 at 16:51
    
Did you recently change nicks ChrisF? –  hbdgaf Nov 29 '10 at 18:00
    
What error do you get when you try to ping google.com? –  Gordon Davisson Nov 29 '10 at 18:31
    
When I do ping google.com I don't get an error, I just get a series of lost packets. However, when I do bzr pull in a repository, I get "Connection error: while sending POST ...: [Errno 51] Network is unreachable". –  Noah Lavine Nov 29 '10 at 19:32
    
What does the output of ifconfig and ipfw list look like? (you may need to prepend sudo to each) –  Zayne S Halsall Nov 29 '10 at 20:14
show 3 more comments

2 Answers

up vote 2 down vote accepted

Can you ping your Gateway or any PC on the same LAN? May be it's just that your school disable ping going out of school network. Networks with lot of users usually block ICMP traffic from going out/getting into their network for security reason. Same for my university here. (Ping use ICMP protocal).

share|improve this answer
    
Yes, you're right. That turned out to be the issue. –  Noah Lavine Nov 30 '10 at 19:37
add comment

Noah: are you connected to a vpn? What's with the en2 and en3 interfaces?

It looks like you have one outward facing ip address on en0, and 2 private IP addresses on en2 and en3 (i assume en1 is airport and it's set to off).

Try disabling en2 and en3 and see if your command line troubles go away. There's a lot of unanswered questions here, but I wonder if you're using a proxy through a vpn for your web surfing...

share|improve this answer
    
also, you might want to check out apple.stackexchange.com. –  Robert S Ciaccio Nov 29 '10 at 22:42
    
I'm not connected to a VPN, but I am on my school's network, which might have a filter on it. I will check on that. –  Noah Lavine Nov 30 '10 at 1:54
    
en2 and en3 are from Parallels virtualization software. Making them inactive didn't fix the issue. –  Noah Lavine Nov 30 '10 at 1:55
    
if you look in your proxy settings for en0, is there anything there? Got to system preferences --> advanced --> proxies –  Robert S Ciaccio Nov 30 '10 at 2:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.