Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to render a 3d model that have been implement uv map in blender. When I press the render button it renders with normal blender material. But I need to render it with uv map textures. please help me.

share|improve this question

migrated from Aug 12 '09 at 7:11

This question came from our site for professional and enthusiast programmers.

Dude, I wish I had a better forum to point you at, I've used myself and think it's a wonderful tool for doing 3d models, but I know they are going to boot this question for not being Programming related. – Pete Eddy Aug 12 '09 at 6:25
Superuser: ewok.adventure is the password. – RCIX Aug 12 '09 at 6:29
up vote 1 down vote accepted

Try clicking the TexFace button in the material settings. This should fix your problem.

More information about applying a UV map in Blender is available here.

share|improve this answer
THANKS......... – Kombuwa Oct 5 '10 at 7:16

You need to create a new material for the object, and in the texture panel of that material, add the image you have uv-mapped to an image texture. Then back on the main material panel, click on Map Input on the far right. Select the UV button. This will tell Blender to put the texture on the UV map coordinates. Now when you render it should show up.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.