Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My HP G60-530US laptop worked fine for both Windows and Ubuntu 10.04 until one day when the Wi-Fi was disabled by the hardware.

For some reason, Ubuntu has stopped enabling the Wi-Fi in response to the button for that, which wouldn't be so bad if I could just reboot into Windows, enable the Wi-Fi, and switch back. Sadly, the Wi-Fi disables itself when I turn on the computer or resume it from standby, which combines with my lack of control in Ubuntu to produce the undesirable result of having to use Windows or connect through Ethernet.

Is this a correctable BIOS problem from HP, an uncorrectable BIOS problem from HP, or just an Ubuntu problem?

If I can fix it, then how do I fix it?

share|improve this question

4 Answers 4

I have an HP G60-635DX. The SAME EXACT thing happened to me.

While I dont know how or why this happens, I know how to get around it.

Under Ubuntu, open Terminal and enter:

     sudo rfkill unblock all

Im not sure exactly how it works, but this enables WIFI under Ubuntu, and should work on many Linux distribs as well.

share|improve this answer

Just press the WiFi button and check that the status of the WiFi is "wireless button networks disabled". Then suspend Ubuntu.

Now enter your password and log in. Check your WiFi status. It will be switched on.

This works on Ubuntu 10.04, 10.10, 11.04, 11.10, …

share|improve this answer
up vote 0 down vote accepted

Well, I have no idea what caused this problem, but I seem to have accidentally done something right. I no longer have this problem. Maybe it's because I accidentally re-enabled HP Wireless Assistant under Windows, but I don't know for sure.

share|improve this answer

What if the WiFi has disabled itself, and you have only Linux installed -- how to unblock it? It turns out not to be straightforward on some modern Linux installations (perhaps, because of strange interaction between 2 modules, or because the device might interpret some incoming tumbler signals wrong). I try to enumerate the suggested solutions I've found (my experiences in Russian):

  1. First, do rmmod -f ath5k, and then rfkill unblock all;

  2. Use the special parameter of ath5k module to ignore the hardware block (because the WiFi-device might receive wrong signals from the button, for example, if the firmware doesn't correspod to way it has been connected, and so on).

  3. Suppress the loading of hp-wmi (BTW, what's the purpose of this module? modinfo says: HP laptop WMI hotkeys driver; "The entry for hp-wifi is for the software that monitors the switch."):

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.