Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an administrator account on this Windows 7 Enterprise x64 machine.

Windows 7 notification area settings are locked. If I right click on the system tray (where the clock is) and click on 'Customize notification icons', the screen that pops up has all the notification icon options disabled so I can't change them. Also at the top it says 'Some settings are managed by your system administrator. Why can't I change some settings?'

If you click on that 'Why can't I change some settings?' hyperlink a help window pops up saying to check the group policy settings. So I open the policy editor and peruse to: User Configuration > Administrative Templates > Start Menu and Taskbar

But all the policies there are 'Not configured'...so I'm assuming that's not the prob? Or I'm looking in the wrong place?

Any ideas how I can unlock the notification icon options?

share|improve this question
    
Let me know if you checked what I suggested. –  SgtOJ Nov 30 '10 at 6:14
    
Can you list everything that is related or has Explorer with in it at the following Registry path... HKCU > Software > Microsoft > Windows > CurrentVersion > Policies. Please include anything from sub of Policies. –  SgtOJ Nov 30 '10 at 9:27

2 Answers 2

Make sure the Always show all icons and notifications on the taskbar is unchecked at the bottom of the Notification Area Icon panel. If it is checked, it will grey everything out.

If the above didn't fix it then check under the Start Menu and Taskbar policy path for Hide the notification area, Prevent changes to Taskbar and Start Menu Settings, and Lock all taskbar settings policy settings. Play with this settings. Remember to set it to not configured if these settings fix the issue. This will prevent future issues related to group policies.

Also, your user could a member of another group, besides the administrators group, that might have same policy enabled*. If that isn't then maybe there is a 3rd party application that is installed and prevent you from change it. There is an example of this at this post.


Information About the Group Policies Refer to Above

More about the Hide the notification area group policy...

This setting affects the notification area (previously called the "system tray") on the taskbar.

Description: The notification area is located at the far right end of the task bar and includes the icons for current notifications and the system clock.

If this setting is enabled, the users entire notification area, including the notification icons, is hidden. The taskbar displays only the Start button, taskbar buttons, custom toolbars (if any), and the system clock.

If this setting is disabled or is not configured, the notification area is shown in the user's taskbar.

Note: Enabling this setting overrides the "Turn off notification area cleanup" setting, because if the notification area is hidden, there is no need to clean up the icons.

More about the Prevent changes to Taskbar and Start Menu Settings group policy...

Removes the Taskbar and Start Menu item from Settings on the Start menu. This setting also prevents the user from opening the Taskbar Properties dialog box.

If the user right-clicks the taskbar and then clicks Properties, a message appears explaining that a setting prevents the action.

More about the Lock all taskbar settings group policy...

Prevents the user from making any changes to the taskbar settings through the Taskbar Properties dialog.

If you enable this setting the user cannot access the taskbar control panel. The user is also unable to resize, move or rearrange toolbars on their taskbar.

If you disable or do not configure this setting the user will be able to set any taskbar setting that is not disallowed by another policy setting.

share|improve this answer
    
The Always show all icons and notifications checkbox is also disabled (I can't tick or untick it...though it doesn't seem like its ticked). I went into the group policy editor and enabled the 'Hide the notification area' but nothing happened or changed =/ –  Richard Maguire Nov 30 '10 at 7:07
    
You want the setting turned to disable. Try that first, if not then set it back to 'not configured'. –  SgtOJ Nov 30 '10 at 7:51
    
The problem is still there even when that policy is disabled :( Though it seems that changes to the group policy don't take effect until you log out and in, hence why when I enabled that policy nothing happened at first. –  Richard Maguire Nov 30 '10 at 9:00
    
Added some other policies to check. Play with them. –  SgtOJ Nov 30 '10 at 9:25
    
Nope, all taskbar properties and start menu settings are fine and able to change them. –  Richard Maguire Dec 1 '10 at 6:56

You can manually edit the policies as SgtOJ was alluding to. Try this:

Open the Registry Editor (Start->Run, type regedit and press Enter) and navigate to the following location:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Check if there is a value named NoAutoTrayNotify. If it is set to 1, please modify it to 0.

Exit the Registry Editor, and log Off/Log On to check the results.

Citation

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.