Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We occasionally connect my wife's laptop, which runs Vista, to our TV. Whenever we do this we have to manually switch the default audio output to "digital output" for the sound to go through the HDMI connection, and we also have to restart any apps that we want to send sound to the TV. We then have to perform a similar process when disconnecting.

Is there any way to just have this be automatic? It seems absurd to have to do so much manual fiddling when a 40 year old transistor radio is "smart" enough to turn off the speakers and send sound to the headphones when headphones are plugged in.

In case it helps, the name "RealTek" shows up in the sound card settings dialog.

share|improve this question
1  
I'd love to know the same thing for Windows 7, although i doubt it would be substantially different. Not enough rep, but I would insert the word "sound" or "audio" in the title - "automatic hdmi audio" is the search phrase I was using when I came across this buried several questions down. –  David Boike Jan 9 '11 at 4:04
    
It's supposed to "just work": Larry Osterman writes about Windows 7 audio Stream Switching, but in your case I guess the alternate audio path isn't actually coming and going, both paths are always available? Is the HDMI cable always plugged in or do you plug it in only when you want audio redirected? If you're plugging it in just-in-time, it may be a driver problem with the HDMI audio (usually part of the videocard driver package, try updating that). –  Ben Voigt Jan 9 '11 at 4:38
1  
@Ben in my case, I'm plugging in the HDMI "just in time". Both audio outputs (internal speakers, aka "default output", and HDMI, aka "digital output") are always available, even when nothing is actually plugged into the HDMI port. The video part works perfectly -- when HDMI is plugged in the additional display is detected. It just continues to send the sound throught the internal speakers. I think all of the drivers were up to date, but I'll check again the next time I use my wife's laptop and update here if that leads to a solution. –  Laurence Gonsalves Jan 9 '11 at 6:55
    
What video card do you have? Some laptops with HDMI out have two sound cards. Mine has a Realtek HD Audio sound card for the speakers and nVIDIA HDMI Audio for the HDMI sound. If I plug in the HDMI, it automatically sets that as the default sound, then switches back to speakers when I unplug it. –  TuxRug Jan 9 '11 at 7:27
    
@tux: I think tux has it right in that the HDMI audio is probably handled by different hardware (the vidcard) than the internal audio. –  horatio Jan 11 '11 at 18:34

3 Answers 3

This might be a solution but I can try...

Depending on how your computer takes the HDMI, if it switches to the HDMI video output but no sound. You can go into sound settings and make the HDMI audio output your default, when you disconnect from the HDMI output, it should automatically go back onto the PC's speakers.

If this doesn't work. I'd suggest upgrade to Windows 7.

share|improve this answer

I don't believe that you can get around the requirement for restarting the application after a sound switch.

For making this less painful, you could maybe use the free Vista Audio Changer :

A system tray application which allows the user to switch their default audio output device at the click of a mouse - useful for users with multiple sound cards, or multiple outputs on a single sound card.

See also Switch default Audio Sound Card from system tray, using the free STADS (System Tray Audio Device Switcher).

Another commercial option may be Coastal Audio Changer (trial available).

share|improve this answer
  1. If the laptop is on power-saver mode, switch it to an Entertainment focused mode or High Performance mode. (I know it seems weird, but I've had issues when in power-saver mode).
  2. Make sure there is NO noise coming from the laptop. Pause movies, pause music, turn off youtube. In fact, best not to have any apps open.
  3. Plug in the HDMI and wait about 10 seconds.

    I've had issues with automatic switching before (because I couldn't figure out how to do it manually) and this seems to be the most consistent way to ensure proper action.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.