Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a 8GB USB flash disk. I created a fat32 filesystem (using mkfs.vfat) on the whole drive (/dev/sdb1).

df -h shows approximately 8GB available, but when I try to extract an archive on the disk, the kernel raises No space left on device exceptions at about 812MB of occupation, and df stills show plenty of space available.

I tried the same manipulation using an ext3 filesystem, without any problem.

share|improve this question
That's definitely not hardware (unless i'm incredibly unlucky). I tried with an other brand new usb drive, with exactly the same result. The system claims "No space left on device" at 812MB. – swordofpain Dec 4 '10 at 23:12
I don't know where the answer is gone, so here is the mkfs command I used : mkfs.fsck -F 32 -n katana /dev/sdb1 – swordofpain Dec 4 '10 at 23:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.