Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Windows 7 Ultimate OS, and my dad recently changed the setting in the sharing tab of my C drive to make it more private when I was using a shared network. Unfortunately, something he did made it so I can no longer access my drive. When I check the owner of the drive it says it is "unable to display current owner." The blue and yellow shield are on all the edit and security buttons making it impossible for me to click them. I have even tried reinstalling windows from my disk, but the computer says I am not authorized to do this.

Other things I have tried: Using command prompt: takeown /f C:\ and then when that didn't work, C:\ /G everyone: F

I even set up the built-in administrator account, but the blue shields are on the buttons there too.

When I try to click on something with a blue shield next to it, the box flashes, but nothing opens.
When I try to open the C drive it says, "C:\ is not accessibly. Access is denied."

I do hope you can help, I am quite desperate at this point!

share|improve this question
    
Can you access other folders like program files? Can you run programs just fine? –  Nori Nov 30 '10 at 16:35
    
I can get to everything in "my libraries." And I can run everything else fine. It's just the C drive that will not open. –  Rose Nov 30 '10 at 17:18

4 Answers 4

up vote 2 down vote accepted

Follow these steps: (these are the steps that resolved Rose's issue)

  • Enabling the built in Adminstrator account via steps below this answer
  • After you enable the built-in Administrator, log off your current user.
  • Then log in to the built-in Administrator account.
  • Then attempt to disable UAC while logged in to the built-in Administrator account. (See Note 1)
  • After disabling the UAC, then reboot your system.
  • Boot in safe mode and change the folder or drive settings. (credit)
  • Reboot and confirm work. (See Note 2)
  • Disable the built-in Administrator account.
  • Enable Window's UAC.

Note 1: Rose used method #2 from this site to disable UAC

Note 2: To be successful, the owner should be set to 'TrustedInstaller' with options to change the owner to one of the computers users.


Steps to Enable the build-in Administrator account: (Source)

  1. Click Start, and then type cmd in the Start Search box.
  2. In the search results list, right-click Command Prompt, and then click Run as Administrator.
  3. When you are prompted by User Account Control, click Continue.
  4. At the command prompt, type net user administrator /active:yes, and then press ENTER.
  5. Type net user administrator <Password>, and then press ENTER. Note: Please replace the <Password> tag with your passwords which you want to set to administrator account.
  6. Type exit, and then press ENTER.
  7. Log off the current user account.

Note: Disable the account when finish for security reasons.

share|improve this answer
    
I did try using the Admin Mode through command prompt, but it was not any different than my account. I also tried to disable the UAC, but the command prompt told me that my access was denied, and the control panel had a blue shield next to the UAC. –  Rose Nov 30 '10 at 17:22
1  
I updated my answer. Try safe mode. –  SgtOJ Nov 30 '10 at 17:24
    
Ditto on safe mode. I've been able to take control of folders that way before that I couldn't in normal mode. For your reference just press F8 while windows is booting to get a option for safe mode. –  Nori Nov 30 '10 at 17:32
    
@Norri - Thank you for the update. @Rose - Please update me if this didn't work. –  SgtOJ Nov 30 '10 at 17:40
1  
Correct, Method #1 is the best way. If the bar is at it low and you are able to submit the changes then reboot the shields will be gone. Shields = UAC... No Shields = Disabled UAC. Also, did you dad turn on parental controls? –  SgtOJ Nov 30 '10 at 19:48

It was finally fixed by taking the following steps.

Enabling the built-in admin account.

Signing on to the admin account in Safe Mode.

Following Method 2 to disable the UAC - http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/

Once the UAC was disabled I was able to sign in normally and take back ownership of the C drive.

Thanks to everyone who helped!!

share|improve this answer

So when you go to properties on the C: drive and then security, can you click on advanced? Assuming you can you can then go to the Owner tab and take ownership of the drive.

What version of windows do you have? Can you ask your dad what tools he used to make the drive more private? It is possible he used the group policy editor or some other 3rd party tool to restrict access.

share|improve this answer
    
Found a setting in group policy that can restrict access to the C drive, but it is user specific. User Configuration\Administrative Templates\Windows Components\Windows Explorer\Prevent access to drives from My Computer –  Nori Nov 30 '10 at 16:39
    
I can get to the advanced page, but it will not let me take ownership. It says it is unable to display current owner, and I cannot click on the edit button to change it to me. –  Rose Nov 30 '10 at 17:24
    
When I try to get to group policy it says "Windows cannot access C:\Windows\systerm32\mmc.exe" –  Rose Nov 30 '10 at 17:26

From your description, you are working with either Win7 or Vista. In these OS's, all user accounts behave like a limited user until they need admin rights. At that point, you are elevated to an admin user and allowed to perform tasks. The blue and yellow shields are a way for the computer to tell you that when you click the button, you will enter admin mode.

What is supposed to happen when you click on a shield is the screen darkens and asks you if you approve going into admin mode. If your user account does not have admin rights, it asks for the credentials of an admin account.

If nothing happens, then you should ask your dad to undo what he did. I would check the user accounts section in the control panel to make sure your account is an admin account. I should note that the default setup for windows 7 and vista, with the firewall turned on, it good enough for most networks. If this computer is at home, then you really don't have anything to worry about.

At worst, you can completely reinstall windows by booting the to the DVD. From your description, you are trying to install windows from inside of windows.

--One last thing--

When you ask for help, make sure to give information about the operating system. It makes it easier for us to help you.

share|improve this answer
    
I am not able to click on the shields. When I click on the links next to the shields, the box flashes, but nothing opens. My dad did all the changes in the sharing tab, which I can no longer access. Thanks for the tip! I edited my initial post. The user account says that I am still an admin. I tried to reinstall windows by booting from the CD, but it said I had to take it out and let the computer start normally before I could reinstall. Thanks for the tip! I edited my initial post. –  Rose Nov 30 '10 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.