Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home build computer that has data corruption problems at boot time. I have exhausted all the troubleshooting steps that I know to try. Do you have any additional troubleshooting techniques that I should try?

Symptoms

I run both linux(ubuntu, mint and fedora) and win7 on this machine. Sometimes I have just one installed. Other times both in a dual boot setup. The OS installs just fine. The system runs just fine for a while. Then it fails to boot. At first I can fix the boot problems with grub or bootrec (/RebuildBcd, /FixMbr or /FixBoot) as indicated by the error messages. Eventually the system fails to boot at all and I have to wipe the disk(s) and reinstall the operating system.

The linux installs seem to last a bit longer. I typically have linux running for a month before the troubles start, but I have to repave and rebuild within 3 months. The windows installs last at most 2 weeks before troubles develop. The system is turned on for the day or evening then turned off overnight.

Once the system has booted all checks that I have run pass. On windows fciv.exe, sfc.exe have never deteced and troubles. On linux tripwire shows everything unchanged. Chkdsk and fsck have never reported errors.

Hardware

ASUS M3A78-EM motherboard. 2x2GB kingston memory from the ASUS QVL for this motherboard. I have used two hard disks in this system. WD caviar black 640G (WDC WD6401AALS-00L3B2). Seagate barracuda 7200.7 (ST3120026A). On some rebuilds I have used just one of the drives, sometimes I have both installed. The DVD burner is a LG 4x (HL-DT-ST DVD-RAM GH22NS30 ). The power supply was originally an el-cheapo Allied unit that came with the case. That has since been replaced with a Seasonic X650.

And that is all that is in this system. I use the onboard video, sound and network. I have never plugged an external device into the system (not even a USB flash drive!).

Trouble shooting so far...

I have run the memtest utility from both the ubuntu CD and the windows DVD many times. Even when run for several day neither test utility has ever found a memory error.

I have run the seagate and western digital provided test and diagnostic tools on both of the hard disks. I have done this on both the unstable ASUS M3A778-EM system and a very stable gateway system. The disks have always tested good.

I have swapped out the HDD cables several times. I have replaced the cables with new cables and with cables pulled from a stable system.

Because the corruption happens only at boot time I suspected the power supply was having problems under the extra load of disk spinup. So, I replaced the power supply. No success.

I have run the system with every version of the MB BIOS from the version that it shipped with to the latest and greatest. The BIOS upgrades made no noticeable difference.

I have enabled and disabled automatic updates on both win7 and ubuntu linux. That made no noticeable difference.

That is it. That is all the troubleshooting ideas I have had. What do you suggest?

share|improve this question
    
As an experiment borrow or buy a quality APC UPS, connect the PC to it, see if the corruption stops, you may be having power surges from your electric provider. –  Moab Dec 1 '10 at 2:44
    
I forgot to mention. All of this time the PC has been plugged into a APC Smart-UPS 1000. –  rschuler Dec 1 '10 at 4:52
add comment

2 Answers

up vote 2 down vote accepted

I actually had the exact same problem with my desktop computer.

After a long time running with no issues, my system stopped booting correctly and would only boot after fixing the mbr. Finally, after a few months of forcing boots, the powersupply gave way and burned up.

I switched out every conceivable piece of hardware except for the motherboard and processor, including replacing the aging IDE drive with a new SATA drive, and a new, more powerful, powersupply. The machine ran perfectly until a month from now when the powersupply burned out again in the exact same manner.

The machien has always been plugged into a high-quality surge protector and no other machines/appliances have been damaged in the building.

After a long while trying to figure things out, I've concluded that there must be some faulty circuit in the motherboard somehow causing the hard drive to receive power-peaks (corrupting the drive on boot) and then slowly damaging the powersupply until it burns out completely.

Sorry I can't provide a better answer, but my problem was solved with a motherboard change. Good luck!

[EDIT]: Looking over your post and at my machine -- It may be a coincidence, but the first hard drive that failed on my system was a WD, the second was a Seagate, and I was running an older Asus mobo.

share|improve this answer
add comment

I hate these kind of problems. Maybe you're just in the line of fire of cosmic rays :p

You mentioned all that I would have tried, including the BIOS upgrades. Good call. All that's left is to swap out each piece of hardware, but that would mean buying a new PC if we consider your time frame of error.

Are there specific signs that you know corruption happens at boot time? Could the corruption happen during any other time, but that it only affect the boot sector? Actually... thinking of this, I wonder if your IDE controller is faulty. See if you can get hold of a new IDE controller, and disable the on-board one.

To make your life easier, I can suggest making a backup of your MBR, so that when this happens again you can just restore the backed up boot sector:

Backup the MBR (in Ubuntu):

sudo dd if=/dev/sda of=/mbr.bin bs=446 count=1

Restore the MBR: Boot into a LiveCD, Mount your root partition and:

dd if=/media/sda/mbr.bin of=/dev/sda bs=446 count=1

obviously /dev/sda will be the primary boot drive for your PC; confirm this with fdisk -l

Alternatively, you can just reinstall the boot loader, GRUB, which will detect your existing Ubuntu and Windows installations. Read here for more details.

Until then, good luck finding the problem!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.