Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently using Google Docs, but when I try to use the keyboard shortcuts like Ctrl+Alt+M it gives µ instead.

alt text

Is Chrome (9) overruling Google Docs in some way?

How can I get these shortcuts working?

I'm using Chrome dev 9 on a Dutch Windows 7 with a US-layout keyboard

share|improve this question
    
See Ctrl+Alt registering as AltGr for US International Alternate, any way to disable? for more general version of this question. –  Piotr Dobrogost Sep 24 '13 at 23:25
add comment

2 Answers

up vote 4 down vote accepted

Here is Google's Official Shortcut Page for Google Doc. There you find that the current shortcut to insert comments is Ctrl + Alt + M and the old shortcut was Ctrl + M. I would have to assume that the old shortcut isn't supported. Which leads to this...

Check this out: (Source - Google Support)

"Originally, US PC keyboards (specifically, the US 101-key PC/AT keyboards) did not have an AltGr key, it being relevant to only non-US markets; they simply had "left" and "right" Alt keys.

As those using such US keyboards increasingly needed the specific functionality of AltGr when typing non-English text, Windows began to allow it to be emulated by pressing the Alt key together with the Control key: Ctrl + Alt ≈ AltGr -- (wiki source).

Therefore, it is recommended that this combination not be used as a modifier in Windows keyboard shortcuts as, depending on the keyboard layout and configuration, someone trying to type a special character with it may accidentally trigger the shortcut, or the keypresses for the shortcut may be inadvertently interpreted as the user trying to input a special character."

US International Layout: Ctrl + Alt ≈ AltGr ... which means... AltGr + M = µ

Note: To resolve this issue switch to a pure US layout, not a US International keyboard layout. See steps below on how to switch.


Windows 7: Switch Keyboard Layout to Pure US Keyboard Layout:

  • Open Start Menu
  • Type in: Region and Language
  • Hit [Enter]
  • [Click] the Change keyboards button
  • Select the General tab if not selected
  • [Click] the Add button
  • Scroll to and expand English (United States)
  • Expand Keyboard if not already expanded
  • [Check] the check box for US
  • [Click] the OK button
  • Select 'English (United States) - US' from the Default input language drop down menu
  • [Click] OK
share|improve this answer
    
Ok, this explains why it doesn't work, but Ctrl + M (as listed in the link) doesn't work. So how can I make it work? –  Ivo Flipse Dec 1 '10 at 9:58
    
Updated the answer. Ctrl-M is an old shortcut. Also Google's doesn't have a more universal shortcut option either. –  SgtOJ Dec 1 '10 at 10:18
1  
The reason is, you are using a US International layout. You need to switch to a pure US layout. Proof is found here. –  SgtOJ Dec 1 '10 at 10:46
1  
So, I want to double check that you have done the steps I just added. BTW, I didnt break it down because I don't think you knew. Instead I did it for future use of the question by someone who might not know. –  SgtOJ Dec 1 '10 at 11:11
1  
@Fuhrmanator that might be a solution for you, but for people working on non-English texts this is definitely a no-go. –  törzsmókus Feb 22 '13 at 10:01
show 9 more comments

You can solve this problem by making sure that Ctrl+Alt+M (or AltGr+M) doesn't yield µ. You can disable µ but keep the rest of your keyboard layout intact.

To do this you can use Microsoft Keyboard Layout Creator. Load your current keyboard layout from the 'File' menu ('Load Existing Keyboard...') and shift state to 'Alt+Ctrl (AltGr)'. Then you can remove µ from the keyboard by clicking it and deleting the character in the popup. Next, build your new keyboard from the 'Project' menu. Lastly, install the keyboard layout from the created setup file and select it under the keyboard layout settings of Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.