Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using the following software:

  • SuSE 11.2
  • Thunderbird 3.1.6
  • Firefox 3.6.12

I created an installation on its own partition both for the user and for Thunderbird mails. For a new installation on another hardware I used this partition. When I wanted to read the emails, I got an error message like this:

The GPG-agent for your GnuPG-version 2.0.12 couldn't get started

Furthermore I got an error message for the access on services of Enigmail:

The file jar:file:///usr/lib/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome/enigmail.jar!/locale/de-DE/enigmail/help/initError.html couldn't be found.

I found out that this path doesn't come from Thunderbird or Firefox, but from Enigmail. I installed several (un-)pack-programs. The only effect was that in the menu of Thunderbird the entry for OpenPGP appeared. The errors as described above repeat every time I try to read an email. I've deleted and reinstalled Enigmail, but the errors don't go away.

What can I do to get rid these error messages?

share|improve this question
    
does the file it's looking for actually exist? if it does, have you tried reinstalling language packs? a lack of responses, says to me that it might not happen in other languages –  hbdgaf Dec 1 '10 at 20:36
add comment

1 Answer

My brother had the same OpenPGP error message in German:

Fehler beim Zugriff auf Enigmail-Dienste
(Translation: Enigmime Service Not Available)

and another window where one of several messages was:

...gnupg\S.gpg-agent':No such file ...

An Enigmail Help error also came up, saying that the file initError.html could not be found in the enigmail.jar archive.

From investigation, we found that the initError.html error message is shown if Enigmail can't find or is not allowed to access GPG. In the German path (de-DE) of the enigmail.jar file, this error message html file is not found - only in the US path - so an error came up.

When we read this message we finally got to the error, see:

http://people.debian.org/~faw/enigmail/enigmail/src/lang/pl-PL/help/initError.html

"In order for OpenPGP to work, the tool GnuPG needs to be installed. If GnuPG cannot be found, then first make sure that the executable gpg.exe (on Windows& gpg on other platforms) is installed on your computer. If GnuPG is installed, and OpenPGP cannot find it, then you need to manually set the path to GnuPG in the OpenPGP Preferences (menu OpenPGP > Preferences)"

The path in the preferences wasn't set as default in our environment because of the problem so we manually set it. After closing Thunderbird this setting was gone again.

We tried then to deactivate our firewall ZoneAlarm and all errors were gone. In the program settings of ZoneAlarm all related programs were allowed, but the errors still occurred. When we changed the program settings in ZoneAlarm from middle to low, the errors didn't came.

Our deeper reason for the problem was that ZoneAlarm was blocking Enigmail from accessing GPG. After uninstalling ZoneAlarm under Windows Vista Business 32-bit and installing it again with administrator rights (maybe it was forgotten on the first install and was the reason?), Enigmail then worked fine - even if ZoneAlarm's settings was for the "middle" level.

Another strange thing is, that the the program gpg.exe and its agent appear several times in the programs in ZoneAlarm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.