Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a Windows 7 machine, with an ATI Radeon HD 5500, and a Samsung SyncMaster P2370MS Monitor. When I use a VGA cable, everything is working fine. But when I use HDMI, the picture is centered, not appearing on the full screen. The whole picture looks a bit squished. I have spent HOURS looking through the monitor settings, updated the driver, googled the problem, and I'm getting nothing.

share|improve this question
    
I had this issue with a Radeon 4890 and a Samsung TV. For nearly year I lived with it and then one day out of the blue the issue resolved itself with the 10.09 or 10.10 Catalyst drivers (I forget which). –  Xantec Dec 1 '10 at 20:34
    
Actually it was the 10.8 drivers as I remember the following line in the release notes HDMI default refresh rate now appears properly as 60 Hz under HDTV in Catalyst™ Control Center as an aside i am still using the 10.8 drivers –  Xantec Dec 1 '10 at 20:44

2 Answers 2

up vote 7 down vote accepted

Enabling GPU scaling should solve the problem.

  1. Open Catalyst Control Center
  2. Select Desktops and Display
  3. At the bottom, click the little arrow on the upper right corner of the selected monitor and click Configure

alt text

In that screen make sure "scale image to full panel size" is selected and GPU scaling is enabled

alt text

If that doesn't solve your problem click Scaling Options at the same screen and scroll the slider to the rightmost.

alt text

share|improve this answer
    
Thank you very much! the upscaling did the trick. I can't believe I have missed that . –  YanivLib Dec 1 '10 at 21:50
    
I wish I could upvote this 100 times! Thanks so much! :) –  Zachary Kniebel Oct 25 '12 at 23:20

This seems like the driver restricts resolution output over HDMI and the monitor adjusts accordingly. I would either 1)accept what it's doing 2)play with resolutions and refresh rates 3)change the monitor 4)go with VGA

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.