Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried nearly everything to get Photoshop to open. I've tried putting a ~ in front of the twian device, as suggested on another site. I've tried running licence recovery as suggested in other places. All of these things seem to work temporarily, and then photoshop goes back to freezing when I try to open it again. I used to be able to re-run the licence recovery and that would fix it for a while, but now that doesn't even work.

I have tried reinstalling. The install runs flawlessly. (It's an install of Adobe Creative Suite Extended CS3). Nothing seems to work.

The splash screen comes up, it runs through initialization, and then just opens to a blank screen with a blank grey area over each of the tool boxes. The entire system slows down to a crawl - it takes about 2 minutes for even so much as a right click to work. I can click on the X to close photoshop, but it takes about 3 minutes to respond. Killing it through task manager takes even longer.

Help! I am going insane looking for answers on the googles.

share|improve this question

Do you have a networked printer set to be your default printer in Windows? If so, try setting your default printer to be a locally-connected one, or that Windows XPS virtual printer thing (sorry, not sure if that's the right name; on a Mac at the moment).

I would always get horrible delays and lag when trying to launch Photoshop CS3 in Windows (and possibly Mac too), whenever I had the default printer set to the HP Photosmart C7280 that I have connected via ethernet. For whatever reason, Photoshop would try to send queries to the printer to gather information about its capabilities or something, but would then sit there for 60 seconds waiting for the request to time out before continuing. As soon as I would set a local printer to be the default, responsiveness returned to normal during launch and print operations, I believe.

Not sure if that is your issue, but it can't hurt.

share|improve this answer

I have read rumors that this fix might solve your problem. Can't promise anything though, and I believe Windows 7 is not supported by CS3.

Also, did you set the Compatibility Options?

share|improve this answer
unfortunately i have tried that particular license recovery tool, and like the other one, it worked temporarily, but then photoshop (the entire adobe suite actually) went back to it's previous bad behavior. I attempted to run it in compatibility mode (tried in both xp and vista, with each type of service pack) and it performed in the same manner every time. – Jessie Dec 2 '10 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .