Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to draw a UML diagram and have become frustrated at the inclusion of some unwanted labels (see circled in red below) when I add composition relationships. When I select them and press Delete I get the following message:

Shape protection, container, and/or layer properties prevent complete execution of this command

Any ideas on how to overcome this?

alt text

share|improve this question

3 Answers 3

up vote 11 down vote accepted

While the statement in the answer above is true it is not the solution to the problem. Most of the UML shapes have a wide variety of display options. To remove the decorations on a UML connector do the following:

  1. right-click the shape

  2. Select "Shape Display Options..." from the menu

  3. Un-check End Options ' "First end name", "Second end name" and "End multiplicities"

  4. (Alternative) In this case you might select Suppress / "First end" and "Second end". Checking the "End Options" turns things on; checking "Suppress" turns things off.

Play around with the other UML shapes to see how they behave.

share|improve this answer
2  
Is there a way to reposition the text labels on certain UML shapes? I want to move some labels on my sequence diagram messages? –  B Johnson Jan 9 '12 at 18:30
1  
Responding to @B Johnson: on the home ribbon, in the tools section, the tool at the bottom of the right column is an A inscribed in a 270-degree arc ending in an arrow head. This allows you to move, resize and rotate text independently of the shape to which it is attached. –  Gdalya Dec 6 '12 at 18:20

That label is probably grouped with other items and cannot be removed.

See if this Microsoft article helps :

Visio: Cannot Ungroup or Modify an Object in Visio

share|improve this answer
    
The steps outlined in your link worked! Thanks! –  Ryan Berger Dec 14 '10 at 4:26
    
On the Window menu.... There is no Window menu! –  Ian Boyd Feb 20 at 16:10

If you disable the Auto assign name to newly created UML model element option in the UML Options dialog (UML -> Drawing Options), Visio will not assign meaningless names to the ends anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.