Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last night I create a new project in Visual Studio 2010, in the folder c:\development\hobby\devices. When I navigate to that folder in a new instance of Windows Explorer, I get the 'This folder is empty.' message in the files pane.

If I then, from within Visual Studio, issue the "Open containing folder command", explorer opens to the folder c:\development\hobby\devices\LoopBack, where loopback is a project under the main folder. If I paste that path into another new instance of explorer, explorer correctly opens c:\development\hobby\devices.

How is this possible?

share|improve this question
Please add the solution as Answer and accept it so the question will be marked as Solved.. – Shadow Wizard Jul 13 '11 at 11:13
Your wish is my command. – ProfK Jul 23 '11 at 21:34
up vote 2 down vote accepted

This is what comes of typing paths instead of selecting them. Some elementary detective work yielded the following interesting results:

C:\>dir dev*.
 Volume in drive C is OS
 Volume Serial Number is E4B4-0563

 Directory of C:\

2010/11/28  09:20 PM    <DIR>          Development
2010/12/01  08:57 PM    <DIR>          Develpment
2010/11/02  06:31 PM    <DIR>          DevTools
               0 File(s)              0 bytes
               3 Dir(s)  63 965 368 320 bytes free

Where my disappearing project was in the badly spelt one.

share|improve this answer

Interesting, something similar happened to me a few weeks ago, a reboot fixed it. But mine was a secondary drive and i assume it had some mounting issues

share|improve this answer

Obvious question: do you have Explorer set to show hidden files?

(Same procedure works for 7.)

share|improve this answer
Yes, but it this case all files are invisible, in one version of the cat, and on the other, they are all visible. The decider is how I open the folder in windows explorer. – ProfK Dec 2 '10 at 16:46

Try to attrib command through the command prompt on the desired folder. I think it will help. you. Here is tutorial how to use the command even it shows the read only attribute so in same way you can remove hidden attribute by typing -h. You can use the command -r -h -s drive:folder path at the same time. Best of luck.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .