Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a registry key under [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run] The value of the key is

"c:\windows\system32\cmd.exe" /c subst t: e:\MyFolder

More often than not when I boot the computer the subst command appears to only half work. If I open a command prompt I can use t: fine. However if I look in windows explorer T: is not there and if I type it into the address bar I get an error message saying "Windows can't find 't:'. Check the spelling and try again."

This is on Windows 7 Enterprise 64 bit.

Any ideas?

share|improve this question
    
i've never used subst myself, but this is what Wikipedia has to say on setting up a persistent mapping. hope it helps –  Xantec Dec 2 '10 at 14:03

2 Answers 2

up vote 9 down vote accepted

This command creates a persistent Z: subst of C:\DirectoryName

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices" /v Z: /t REG_SZ /d "\??\C:\DirectoryName" /f
share|improve this answer
    
+1. Still works in Windows Server 2012. Needs a restart. –  Neolisk Jan 7 at 18:50

This probably happens because the run command runs elevated (as administrator). If you run the subst command not elevated you will see it in Windows Explorer. You can test this running the subst on an elevated command prompt.

share|improve this answer
    
I tried this, but it still didn't take. –  Jim Fell Mar 23 '13 at 20:47
    
Did not believe this would work, but you were right! it worked i mapped my dropbox to Z: on the fly. well done –  Mickey Perlstein Feb 8 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.