Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Visio 2007 Profession SP2 on Windows 7 Enterprise x64. I have a rather complex ER database diagram I've been working on a few weeks. It does use some non-ER shapes for callouts and notes. It's a multi-page diagram, as well. (Essentially one SQL 2005 schema per page.)

The stock database add-in itself (that is, the one which ships with Visio Professional) appears to be running: I have the Database Menu, I see the Tables and Views window, etc. However, double-clicking an entity or attempting to access the Database Properties window fails: It appears to do nothing. No hourglass, no display, no message, no nothing. It does this not only in my complex document, but in brand-new blank database documents as well.

Regarding what, exactly, is failing:

  • Double-clicking an entity on the diagram
  • Double-clicking a table in the Tables and Views panel
  • Right-clicking an entity and selecting "Database Properties"

Other aspects of the database add-in seem to work:

  • The Reverse Engineer wizard starts
  • Removing a relationship from the diagram, then right-clicking the entity and selecting "Show Related Tables" brings it back
  • Changing the relationship display to (and back from) "Crow's Feet."

It worked Tuesday, which was the last time I worked on this file. As far as I'm aware, nothing has changed since then, however, I did not use this computer but for perhaps an hour on Wednesday -- and that was remotely, through Terminal Services. At that time, I closed Visio to reduce the clutter of open applications (I rarely turn this machine off, and usually leave my work open for days on end). For all I know, a Windows Update ran sometime between Tuesday 5 PM and 9 AM this morning, but I couldn't tell you if that's the case. (This is a work machine, on a domain; I'd have to check with my administrators to see if we're using WSUS to push those or if we're just reliant on Microsoft's schedule.)

The machine may or may not have been involuntarily rebooted between Tuesday evening and this morning. However, I have since manually rebooted it, and there's been no change. I've also tried starting Visio in Safe Mode, and again, no change (neither in Safe Mode, nor since). There does not appear to be any information in the Application event log, nor any of the Office-specific event logs.

Other add-in-requiring templates (such as the UML template) appear to be working correctly, displaying their custom properties windows. It's just this one.

So, long story short: (I know, too late):

  1. Why would the Database Properties window stop appearing?
  2. What can I do to get it back? (I really need to update the documentation on some of these entities!)
share|improve this question
    
Did the machine reboot? It's hard to tell from your question. If not, I'd reboot and try again. –  user3463 Dec 2 '10 at 18:07
    
@Randolph: Reboot did not help. –  John Rudy Dec 2 '10 at 19:37

1 Answer 1

up vote 1 down vote accepted

It appears that Visio doesn't work and play well with going from a multiple monitor setup to the compressed display of terminal services. The Database Properties window somehow moved off-screen. Oddly, this was occurring now that I'm sitting at the desktop, in all its 3-monitor glory.

Running the VBA found here brought it back for me. In case that link ever dies, here's the script. Paste it into the ThisDocument section of the VBA editor:

Sub GetDbWindow()

Dim win As Visio.Window
For Each win In Visio.ActiveWindow.Windows
    If win.Caption = "Database Properties" Then
        Call win.SetWindowRect(0, 0, 200, 200)
        Exit For
    End If
Next win

End Sub
share|improve this answer
    
Please accept your own answer to this question to prevent it from being bumped to the front page again. –  Daniel Beck Apr 24 '11 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.