Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an EzCap 116 capture device, which can capture video and audio from composite cables.

I capture the video in VirtualDub using its "Capture AVI" function. VirtualDub apparently encodes the video into .avi with the MPEG-1 codec and generates the video file.

These play perfectly in VLC.

However, I would like to do some editing in Sony Vegas. At first, I was getting an error, Video: stream attributes could not be determined., which I determined was a codec issue after some Googling. After playing around with the ffdshow VFW configuration, I was able to make Sony Vegas recognize and play the video file.

The problem is that the quality is absolutely awful in Vegas. The picture is blocky, wavy and very laggy. I don't understand why it would be, because like I said, these videos play perfectly in VLC and in VirtualDub.

I have a video example of the problem, which can be seen here:

http://www.youtube.com/watch?v=53eHQ4B0-0o

(I know the audio is off, that's not my concern at the moment)

Why is Sony Vegas violently butchering my video stream? I've never dealt with this problem before.

share|improve this question

2 Answers 2

up vote 2 down vote accepted
+100

This is a codec problem. VLC contains its own codecs, which apparently deal very well with the AVI produced by VirtualDub.

Sony Vegas, on the other hand, is said not to work well with Divx or Xvid. MPEG is actually said to be fine.

I suggest that you should first install a good codecs pack, such as K-Lite and try again, verifying the video parameters in VirtualDub. If this doesn't work, then try encoding in VirtualDub to something less compressed. Try even capturing in lossless avi format, if the computer is fast enough. If not, try maybe MPEG-2, recommended in some threads for Sony Vegas.

The general rule of thumb is: the less compressed, the easier to edit and the better the quality of subsequent encodes. If it is the final product, then you can compress as much as you want and get your desired level of image quality. Uncompressed files are also relatively huge and require long processing times to convert, so a certain balance between encoding and quality is required.

Video operations rely hugely on your hardware. So it is generally a matter of try and see what is best for you.

share|improve this answer
    
yes, +1...additional note: ffmpeg is in K-Lite and is what vlc uses to do most of its magic –  hbdgaf Dec 8 '10 at 14:11
    
hmm... K-Lite offers a few more codecs under VirtualDub's compression menu, which each render differently when played back in VLC/Vegas. Nonetheless, this is a great start and a bit of configuration will probably solve my problem. –  Corey Dec 11 '10 at 21:54

Reading you post again it seems you have ffmpeg installed already(ffdshow is a component of the ffmpeg set). I'm thinking Sony Vegas is trying to use ffdshow to convert to some other format on the fly. ffmpeg default bitrate is 200k/s according to: http://www.linuxquestions.org/questions/linux-software-2/ffmpeg-to-convert-quicktime-mov-file-into-dv-file-635594/ which is WAY too low for a lot of video types during editing. I would try converting the stream to a Vegas native supported format like DV(according to wikipedia Vegas 8 supports DV format out of the box). Then use dv file. You state in your post that you can handle the audio stuff, so this is just a recommendation for video.

share|improve this answer
    
Well, the audio lag isn't part of the problem, it's a known issue regarding VirtualDub's capture feature. There are options to sync while recording, but it causes input delay and also modifies video frames to fit the audio -- good for recording a VHS tape, bad for playing video games. –  Corey Dec 11 '10 at 5:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.