Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get the numpad Enter key to work on OS X 10.6.5. The numpad works fine, as do the plus and minus keys. Only the Enter is not working.

I tried 2 keyboards and I get the same problem with both, so it's got to be a setting somewhere. In Keyboard Viewer, when I press the key, it shows that the ⌘ keys are pressed. And indeed, pressing Enter-L puts the cursor in the location bar of my browser, just like Command-L would. Is there a way to remap it?

share|improve this question
    
Just in case it might help: Apple keyboards distinguish Enter and Return. Indeed, the numeric part has an Enter key, which is not the same as the Return key. Hence it might not work as expected when entering text. Older smaller keyboards may also have an Enter key to the right of the Space bar, often labeled as ⌅ (which recently became a second Option key instead). –  Arjan Dec 3 '10 at 15:06
    
Does Keyboard Viewer show the key being pressed down when you press it? (System Preferences, Input Sources, Keyboard & Character Viewer, and then select it from the menu bar next to the clock.) –  Arjan Dec 3 '10 at 15:10
    
No, in fact when I press it it shows that the ⌘ keys are pressed. That's weird. –  user19294 Dec 3 '10 at 15:18
1  
And does it indeed work as the Command key then? Like Enter-L would put your cursor in the location bar of your browser? –  Arjan Dec 3 '10 at 15:26
2  
Do you use software such as DoubleCommand or KeyRemap4MacBook, or any Input Managers? –  Daniel Beck Dec 3 '10 at 16:16
show 2 more comments

2 Answers

up vote 5 down vote accepted

Since my comment fixed your issue, I'm posting it as an answer:

You had DoubleCommand installed.

alt text

Other possibilities would have been KeyRemap4Macbook or possibly any Input Manager.

share|improve this answer
1  
Argh, thanks! I don't know why they thought "Enter Key acts as cmd key" would be a good default. –  nathan.f77 Jul 24 '13 at 22:30
add comment

I would check this post. I don't have my macbook to try it out myself but there were two potential solutions. Either using a program called Double Command or looking under the system preferences for modifier keys.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.