Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Samsung 80GB SATA II drive in a machine with the following specs:

  • AMD Athlon 64 3800+ @ 2.4 GHz
  • 4x 512MB PC3200 DDR400 SDRAM
  • HIS Radeon HD4350 256MB DDR2
  • Windows XP Professional 32-bit

After installing all the drivers and basic programs, I decided to defragment my hard drive. However, it appears that no matter how many times I run the Windows defrag program, it will never go below 15% fragmentation. I know many will suggest using Smart Defrag or Defraggler, but for XP, I normally use the default program because I know that it works. However, in the case of this machine, it just won't defrag to 0%.

What could be the cause of this?

NOTE: Computer is having boot problems. It seems that if the computer was shut down completely, and then started up, it won't completely boot into Windows, eventually resulting in one long beep repeating on-and-off from the BIOS. Being an AWARD BIOS, it appears to be some sort of memory error. However, reseating the RAM always fixes the issue and the machine starts up again. I very recently ran Memtest86+ on the RAM with no errors. What should I do to ensure it starts up every time?

The hard drive matter was not resolved "properly" as Defraggler was used to bring drive fragmentation down to zero. However, more serious matters about the machine will be brought up in a new question as there are too many answers and/or upvotes for this question to be deleted. The most appropriate answer for this question will be marked as correct.

share|improve this question
    
the system is just not being very clean about where it saves files apparently. –  Xantec Dec 3 '10 at 16:50

5 Answers 5

up vote 3 down vote accepted

My guess would be that the unfragmentable files are large ones and you don't have sufficient free disk space to fully defragment them using XP's defragmenter. Do you get a message pre-defrag warning about less than 15% disk space free?

share|improve this answer
1  
They could also be unmovable, like the page file. –  Joel Coehoorn Dec 3 '10 at 17:24
    
Sometimes very large files will just not defragment, not sure why but I had this problem once in XP, I copied the file off and then deleted the original, then copied it back, all was fine after that. You may need to run a chkdsk /f on that hard drive, if there are file system problems it can cause this also. –  Moab Dec 3 '10 at 17:26
    
The unmovable files would also include the files used for the System Restore service. The Disk Cleanup wizard will have an option to delete all but the last restore point which can get rid of some of the unmovable files. –  Mokubai Dec 3 '10 at 18:36
    
Page file doesn't usually fragment like crazy all over the disk, though - default settings seem to give it a static size of 1.5*RAM. System Restore files are defragmentable, though - I've just done it. –  CodeByMoonlight Dec 3 '10 at 20:06
    
Ah, that would be one difference between Vista and XP then, my mistake. On Vista and Win7 they are not defragmentable without deleting, I assumed the same would be true on XP. At least they are not movable for me using MyDefrag... –  Mokubai Dec 3 '10 at 20:24

The "IRQL_NOT_LESS_OR_EQUAL" is produced by Windows; your BIOS is successfully finding your boot volume, and initiating the Windows boot. It's most likely not a CPU error.

The error you're seeing is most likely due to a corrupt registry.

Does your computer immediately reboot itself after you see the BIOS info? Are you ever able to successfully boot into Windows? If your computer just keeps restarting itself, press F8 as soon as you see the BIOS screen, and select "Disable automatic restart on system failure". This will allow you to at least all the information associated with the error. Are you able to boot into safe mode, using the F8 list?

share|improve this answer
    
No; it actually freezes at the BIOS screen and I can't do anything but force shutdown, no matter which F-key shortcut I try. If it does go past the BIOS screen, the BSOD will come even before the Windows logo with the scroll bar. After that, it'll just load up the BIOS screen and freeze there. –  Wesley Dec 6 '10 at 3:39
    
Are you able to enter the BIOS itself, or do you experience lockups then as well? –  geodave Dec 6 '10 at 3:42
    
Like I said, my machine freezes on the HP BIOS screen and pushing F1, F10 or Esc - setup, system recovery and boot menu, respectively - does not trigger any response; it's just frozen. –  Wesley Dec 6 '10 at 13:51

What does the defrag analysis say? I'd guess that the undefragmentable files would be either large files and/or system files (MFT, page file, hibernation file etc). These pose a major problem for the default defragger which cannot defragment many system files and struggles in low disk space conditions. AFAIK, the free third party utilities aren't any better at this, only the commercial defraggers preform well in this scenario. I'd suggest downloading the free trial versions of a decent automatic defragger (set & forget types) and using it for it's evaluation period. It'll function exactly like the full version for that period, and you can get your work done.

As for the BSOD, I'd start with the drivers, especially if there are known incompatibilities between your hardware components. Update to the latest drivers for all your hardware. I'd also disable all but the most essential items in the startup list while troubleshooting the BSOD.

Running chkdsk /r might help to fix any filesystem errors; do this before the defrag.

share|improve this answer
    
As mentioned before, it's not booting up. So until I solve the boot problem, I won't be able to do anything. –  Wesley Dec 6 '10 at 16:33

It sounds like you may have some errors related to your memory. Instead of reseating the memory, have you tried removing all of the memory except for one stick and seeing if that's the error? I'd test each stick like this and see what happens.

share|improve this answer
    
Well, I thought running Memtest86+ on all the sticks would still detect errors if there were any. Anyways, I tested individually with no error coming up. I reset CMOS and have yet to try a cold start. –  Wesley Dec 10 '10 at 3:12
    
If using the memory individually didn't work, I'd say your motherboard is toast. –  Nic Dec 10 '10 at 23:40
    
Even though it boots properly occasionally? –  Wesley Dec 11 '10 at 23:11

I got the same booting problem yesterday. I have Win7 64bit. Problem is not related to drivers or operating system, because I got similar symptoms with two individual Windows 7's installed on my computer. Sometimes the computer can stay on for 5-10 minutes and then it reboots, sometimes it freezes in the bios booting stage.

My power supply has made some noise recently and I think insufficent power is the problem. If replacing power supply doesn't work, then broken motherboard is my best guess.

share|improve this answer
    
If it's not the power supply, try your RAM in another computer. This was my problem. I tested the RAM for several passes, but it didn't detect any errors... it was just faulty. –  Wesley Dec 23 '10 at 16:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.