Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to compile gimp (git version), and I installed gegl 0.1.2 without problems. The problem is when I try make gimp. I don't know why happend this error help!

share|improve this question
1  
Full error log, please. – Sathya Dec 4 '10 at 4:25

You have to compile git version of gegl and babl:

$ git clone git://git.gnome.org/gegl
$ git clone git://git.gnome.org/babl

If you are getting this error while compiling babl:

/home/arzeth/compile/babl/babl/babl-types.h:23:2: error: #error "babl-version.h must not be included directly, include babl.h instead."

then remove these lines in those files:

#ifndef BABL_INSIDE_BABL_H
#error "babl-version.h must not be included directly, include babl.h instead."
#endif
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .