Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Note: I am NOT referring to Internet Explorer.

I am using Windows XP and Windows Server 2008 and need to delete the history values from the file browser (aka Windows Explorer). Somebody put a password into the address bar as ftp://user:pass, and now I can't delete the value.

Some forums say to delete this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\TypedPaths

In Windows XP, the key doesn't exist, and in Windows Server 2008, the key is there, but deleting it doesn't seem to help.

The answer

For XP, you need to use CCleaner, select delete History and Recently Typed URLs from Internet Explorer and Recent Documents and Other Explorer MRUs from Windows Explorer

For Windows Server 2008, log into the FTP site, press ALT, then do File > Login, at which point you can change or delete the password.

share|improve this question
    
did u run regedit as the user that was having the problem or as an admin? –  user33788 Dec 3 '10 at 22:10
    
as the user that had the problem. –  mlissner Dec 5 '10 at 4:39
add comment

3 Answers

Use CCleaner to get rid of 'em.


Also, check if the entry exists in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

share|improve this answer
    
I'll try CCleaner. The key you mention above exists, but it doesn't seem to have any history values. –  mlissner Dec 6 '10 at 18:17
    
I installed CCleaner, deleted History and Recently Typed URLs from Internet Explorer and Recent Documents and Other Explorer MRUs from Windows Explorer, and that finally worked, thanks. –  mlissner Dec 6 '10 at 18:35
    
Good to hear @mlissner, you're welcome! –  Sathya Dec 6 '10 at 18:52
    
Hrm...had this problem again, and CCleaner didn't work this time. This was on Windows Server 2008. I think last time was Windows XP. –  mlissner Jan 13 '11 at 21:33
add comment

When clearing Internet Explorer history, does it also clear the Windows Explorer's?

Right-Click Start button > Select Properties> Click Customize > Click Clear

share|improve this answer
    
Hmmm...great theory, but didn't work.. –  mlissner Dec 3 '10 at 21:53
    
No, clearing IE's history doesn't do it either. Any other theories? –  mlissner Dec 6 '10 at 18:11
    
For me worked on Windows XP. –  ybungalobill Jan 29 '13 at 7:51
add comment

I've just struggled to achieve this in Windows 7

I had to delete entries from both:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

and

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths

But I also had to kill Explorer.exe (using Windows Task Manager [SHIFT+CTRL+ESC]) or else the typed Paths kept coming back.

Note: Open regedit first and then kill explorer.exe and then use the File > New Task (Run...) menu option to re-spawn explorer.exe. Just enter explorer.exe in the run box and hit Enter

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.