Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Win7 and IE8.

In IE8, when I CTRL-CLICK a link to open a new tab, if Synergy+ Server is running, the link opens in a new window, not a new tab. If I stop the Synergy service, normal behavior returns. If I start the service again, the problem returns.

I thought maybe Synergy was throwing away the CTRL key. However, if I click "Open in new tab" on the context menu, I also get the same incorrect behavior.

Sometimes, not always, if I click the "new tab" tab, nothing happens.

Again, in all these cases, if I stop the Synergy service, normal behavior returns. If I start the service again, the problem returns.

I have not been able to reproduce the problem in Chrome or Firefox.

Does anybody have a solution or explanation for this problem?

Thanks in advance, Steve.

UPDATE: CTRL-ALT-RIGHTARROW in iTunes normally skips forward, with Synergy running, it jumps to next item in the playlist, normally caused by just a RIGHTARROW. So again, it appears that at least part of what Synergy is doing is throwing away control keys.

share|improve this question

migrated from stackoverflow.com Dec 4 '10 at 12:41

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I'm having the same problem when I run Synergy with administrator privileges (otherwise it will not work when I try to switch desktop and I'm working in a active program running as administrator).

My best guess is that this problem is due to the security hardening done around IE to protect against drive-by-downloads, etc.

The solutions I found to this problem(s) are:

  1. Run Synergy with normal user privileges.
  2. Run Synergy and IE with administrator privileges.
  3. Run Synergy with administrator and run another browser as the primary web browser.

So it's not a big problem for me since I prefer Firefox, but a final solution would be nice. (oh btw, I'm running Synergy+ 1.3.4 Server on Microsoft Windows 7 x64)

Edit:
I tried the 1.4.1-Windows-x86.exe beta today and not experienced any of the above problems (or any other for that matter).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.