Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a rather annoying problem I have with Linux on my laptop. Whenever I install any Linux distro that relies on grub (which is about 99 % apparently) it will mess up my DVD-drive and the drive will not be recognized after booting, no matter the OS (Ubunntu, Arch, Windows Vista or 7).

I know the problem has nothing to do the DVD-drive itself, because I bought a new one a few months ago. I am also sure that grub is messing the drive up, because I have tried to use LILO, which worked fine (except for horrible boot times.)

This problem have persisted through about 3-4 years and it is a pretty bad show stopper whenever I want to work with Linux. I had hoped it would get fixed over time, but no one seems to have the exact problem I have. The drive is connected with an IDE connection.

Update: The old drive was a Toshiba Samsung SN-S082. I don't know the model number of the new one, but it is HP (I think).

Things I have tried to fix it: Mess about with some BIOS settings like enabling AHCI and change some IDE settings. Installing a different boot loader DOES fix the problem but I would like to use grub.

share|improve this question
    
Could you add the model of the DVD drive and what you tried to fix this problem so far? Does the drive reappear when you remove grub? – user54114 Dec 4 '10 at 20:23
    
The drive will indeed reappear as soon as I use something else than grub. The old drive was a Toshiba Samsung SN-S082. I don't know the model number of the new one, but it is HP (I think). – drblah Dec 4 '10 at 20:28

This seems to be a known bug in Grub, but you probably know this already. At the linked site turning off acpi is mentioned, have you tried this?

share|improve this answer
    
It is disabled. EDIT: no wait, I thought you said AHCI. – drblah Dec 4 '10 at 21:01
    
It does not fix the problem. – drblah Dec 4 '10 at 21:25
    
Then I'm out of ideas, sorry. – user54114 Dec 4 '10 at 21:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .