Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

not sure what i am missing here..

every website suggests creating this reg key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents

as DWORD and setting its value to 0xFFFFFFFF

i've done this, but when i reboot, my NIC adapter still shows IPV6 enabled.

since i have 64bit version, i also tried setting this value as QWORD. what am i missing here?

share|improve this question
up vote 3 down vote accepted

Just because it's turned off in registry doesn't mean your check box on NIC will dissapear. It just means it's disabled. Just to be sure I usually do it in both places (in registry and NIC properties). For Windows 7 however doing it on NIC properties should be enough, but for Exchange 2010 (as a side note) it brings Windows Server to knees.

Couple of ways to disable IPv6 completely (just for answer completeness):

  • Run this from command prompt reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 255 and then reboot.
  • Run this Microsoft Fixit utility http://support.microsoft.com/kb/929852

Some helpful links:

share|improve this answer
    
ok, how can i verify my registry change worked? and should i be using DWORD in 64bit windows? – Sonic Soul Dec 4 '10 at 22:33
1  
Running this from prompt should do it: reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 255 but it's exactly as you already did it. You could verify it with ipconfig /all in cmd window. – MadBoy Dec 4 '10 at 22:37
    
ipconfig -all doesn't say anything about ipv6.. also should be using DWORD (32bit) value in 64bit windows? or QWORD ? – Sonic Soul Dec 4 '10 at 22:40
    
windows7themes.net/disable-ipv6-windows-7.html here's a good link to get you thru. When i did ipconfig /all on my machine it shows: Link-local IPv6 Address . . . . . : fe80::4c50:ae33:88df:5fae%12, IPv4 Address. . . . . . . . . . . : 192.168.20.29 – MadBoy Dec 4 '10 at 22:44
1  
See the "applies to" section of that MS link I posted, DWORD 32bit applies to 64bit versions also. – Moab Dec 5 '10 at 3:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .