Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use our VB6 software application with SQL Server 2000 from out side.

I have given static IP of Server in application for connection purpose.

It is working fine but after 1 or 2 days application is not accessible from outside and in our LAN.

our ISP told me to port forwarding but i am not a Networking guy.

Any one have a idea so solve this issue ASAP.

share|improve this question

1 Answer 1

Port forwarding is setup in your gateway/NAT. Most of these devices have some kind of web interface for configuring them.

The concept of port forwarding is the gateway will route requests to its 'public' address on a specific port to a specific internal address on the same port.

FYI: SQL server 2000 using port 1433

Setup your gateway to forward port 1433 to the internal static address you setup for your SQL server, and direct your VB6 application to connect to your gateway/nats 'public' address and you should be in business.

There could also be something else going on here if your being disconnected internally and externally. If your using a named instance of SQL server, your port might be configured dynamically. You'll need to set this to a static port in order to use port forwarding. http://benchmarkitconsulting.com/colin-stasiuk/2009/02/02/what-tcp-port-is-sql-server-running-under/

share|improve this answer
    
Thanks for reply, –  Praveen M Tripathi Dec 6 '10 at 6:35
    
We are using LinkSys Router and we dont hv port fordwarding option in this router. –  Praveen M Tripathi Dec 6 '10 at 6:37
    
So please suggest me how to solve this issue and how to forward port 1433, –  Praveen M Tripathi Dec 6 '10 at 6:38
    
You'll need one that does this. Sometimes its not obvious where these options are. On the linksys WRT54G, those options are under "applications and gaming" menu. –  txyoji Dec 7 '10 at 3:05
    
We have Linksys RV042 Router and we dont hv this option. –  Praveen M Tripathi Dec 7 '10 at 3:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.