Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Fedora 13 installed on my laptop. For some reason it always seems to run at 1GHz even though the maximum is 1.67GHz (even under 100% load).

The output of cpufreq-info:

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, userspace, performance
  current policy: frequency should be within 1000 MHz and 1000 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz (asserted by call to hardware).
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, userspace, performance
  current policy: frequency should be within 1000 MHz and 1000 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz (asserted by call to hardware).

I tried changing the limits by setting cpufreq-set -r -g userspace -c 0 -d 1000MHz -u 1670MHz but the output it still identical (in particular "frequency should be within 1000 MHz and 1000 MHz").

Any ideas how to change the limits?

share|improve this question

2 Answers 2

Why are you using the userspace governor? According to the Linux kernel documentation (Documentation/cpu-freq/governors.txt in the kernel source code):

The CPUfreq governor "userspace" allows the user, or any userspace program running with UID "root", to set the CPU to a specific frequency [...]

IMHO this also implies that the cpu frequency won't adapt to the load when this governor is selected. I would suggest you to switch to the "ondemand" or "conservative" governor and see what happens when the CPU is under load. I hope this will solve your problem.

share|improve this answer
    
I have tried the other governors, the frequency does not change when using those. I tried the userspace one so I could rule out any problems with the other governors. –  pafcu Dec 8 '10 at 18:58

You have to pass the frequency in terms of KHz:

cpufreq-set -c 0 -f 1670000
share|improve this answer
2  
From the Fedora manpage: "FREQuencies can be passed in Hz, kHz (default), MHz, GHz, or THz by postfixing the value with the wanted unit name, without any space" –  pafcu Dec 5 '10 at 12:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.