Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a 15 inch unibody MacBook Pro. So far I've been using WiFi and everything worked well. I've just switched to wired network and the machine doesn't seem to detect the network cable when it's plugged in. It works when I use the same cable with a PC, so router and cable seem to be OK.

When I look at Network Preferences while plugging the cable in, it changes to yellow light and says "No IP address" for a second and then switches back to "Cable unplugged". I've tried adding new location and using static IP, setting DHCP manually etc. Sometimes Network Preferences showed green light and everything seemed fine, but there was still no connection.

Any ideas what's wrong?

share|improve this question

1 Answer 1

If it is switching between no ip and "cable unplugged", you might actually have a hardware issue and a dying network port. You sound like you have gone through many of the same options/troubleshooting I would do. Your machine is under warranty, so I would take advantage of it now.

1-800-MY-APPLE

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.