Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a machine running Windows 7 Home Premium x64.

IIS7 is up and running; I can navigate to localhost:80 and the spiffy IIS7 welcome screen appears.

When I try this on any of my other machines, the request times out. And, yes, I can successfully ping the IIS7 host machine from the other machines.

I've tried looking over the IIS7 documentation, and the answer is probably there but I can't find it.

Or is it maybe something to do with Windows 7 security?

Thanks.

share|improve this question

migrated from serverfault.com Dec 6 '10 at 8:14

This question came from our site for system and network administrators.

    
I was having a similar problem (with Windows 8), was pulling my hair out -- I had turned off all firewall rules, triple checked bindings, iisreset, you name it. Turned out, chrome on my client PC was blocking it, because it had decided that 6666 was an "Unsafe Port". –  BrainSlugs83 Mar 15 '14 at 20:50

5 Answers 5

Perhaps it's the Windows Firewall (or a 3rd party one) blocking that traffic...

share|improve this answer

Are you attempting to connect to the web server by IP address? To isloate DNS, you may want to try connecting by IP address.

And I agree that Windows Firewall is the most likely culprit here. If you can rule out the firewall, you may want to verify the bindings of the site both from the IIS Manager and through something such as:

NETSTAT -noab > out.txt && out.txt
share|improve this answer

From the remote machine try doing a telnet to port 80

telnet SERVER_IP 80

The 80 in the end is important because it tells telnet to connect to port 80. If you can't connect then I would check the windows firewall and IIS configuration. In that order.

share|improve this answer

Attempting to web develop across Windows Home Group, you must turn off the "Home or Work" (local) FireWall on the IIS machine for the other machine on the Home Group to see the application.

share|improve this answer

It's the Windows Firewall most likely. Search for Firewall and you'll get the Windows Firewall dialogue box. Add a new Inbound Rule. Choose the predefined World Wide Web (http) rule and enable it.

Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.