Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu 10.04 through the Wubi installer (Funny, I installed it today and thought I would have gotten 10.10). I had a network connection and everything was working fine. I rebooted my coumputer a couple of times and then suddenly, I could not connect to the network and when I click the wireless/networking icon it says "Networking Disabled".

I reinstalled Ubuntu and the problem went away. After a few reboots the problem returned. I have tried restarting to see if it would come back as well as a few other things listed below. Any other suggestions would be appreciated.

Tried to restart networking via /etc/init.d/networking:

amato@ubuntu:~$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                          Ignoring unknown interface eth0=eth0.
                                                                         [ OK ]

Tried to stop and start it:

amato@ubuntu:~$ sudo /etc/init.d/networking stop
 * Deconfiguring network interfaces...                                   [ OK ] 
amato@ubuntu:~$ 
amato@ubuntu:~$ sudo /etc/init.d/networking start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service networking start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start networking
networking stop/waiting

Tried start networking:

amato@ubuntu:~$ start networking
start: Rejected send message, 1 matched rules; type="method_call", sender=":1.58" (uid=1000 pid=2241 comm="start) interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init"))
amato@ubuntu:~$ sudo start networking
networking stop/waiting

Tried service networking restart:

amato@ubuntu:~$ service networking restart
restart: Rejected send message, 1 matched rules; type="method_call", sender=":1.60" (uid=1000 pid=2248 comm="restart) interface="com.ubuntu.Upstart0_6.Job" member="Restart" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init"))
amato@ubuntu:~$ sudo service networking restart
restart: Unknown instance: 

Here are the contents of my /etc/network/interfaces.

auto lo
iface lo inet loopback

I even tried to modify it to this (based on something I read, online, not sure if I was doing the right thing here). Tried everything again and no luck:

auto lo eth0
iface lo inet loopback

iface eth0 inet dhcp
share|improve this question

migrated from stackoverflow.com Dec 6 '10 at 12:01

This question came from our site for professional and enthusiast programmers.

    
probably fits better in askubuntu.com or superuser.com –  andreas Dec 6 '10 at 6:17
    
DHCP or static configuration? Show us your /etc/network/interfaces –  Oleksandr Kravchuk Dec 6 '10 at 9:46
    
This could be a transient problem — how good is your wifi reception? Does your wifi network have a password? When you try to connect to the network (with the GUI or with sudo service networking restart), what messages appear in /var/log/syslog? –  Gilles Dec 6 '10 at 20:57
    
Could you also post the output of ifconfig which aide in diagnosing what's going on? –  M. Tibbits Jul 1 '11 at 6:37
    
Also check out my answer here –  mike Nov 30 '11 at 22:26

3 Answers 3

This previously happened on my laptop - turned out I had accidently hit the switch that kills the wifi, and Ubuntu didn't turn the wifi back on once I turned the switch on. I solved it with:

rfkill unblock wifi

Give that a shot.

share|improve this answer

If you tried sudo start networking or sudo service networking start and received networking stop/waiting then you probably don't have things quite properly configured.

In your /etc/network/interfaces file:

auto lo eth0
iface lo inet loopback

iface eth0 inet dhcp

Implies that eth0 is the physical adapter which is currently plugged into your internet connection. My hunch would be that for some reason you're having a conflict with another device which is trying to use the same ip address. So you might try using a static ip address (If you're using a router which supports dhcp - e.g. Linksys/Cisco):

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address 192.168.1.200
    netmask 255.255.255.0
    gateway 192.168.1.2

Where 192.168.1.2 is the address of your router. Also check out this question.

share|improve this answer

In my case http://unix.stackexchange.com/questions/37122/virtualbox-two-network-interfaces-nat-and-host-only-ones-ina-a-debian-guest-o solved it.

Added these lines in /etc/network/interfaces:

allow-hotplug eth1
iface eth1 inet dhcp

then run ifup eth1

thanks to brandizzi!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.