Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've used Ubuntu (Jaunty / 9.04 is the version in question) in my development laptop for last two years. For two days my CPU constantly has 100% usage. I can see in "htop" and "gnome-system-monitor" that Firefox 3.5 and Xorg is competing at the top for CPU resource. If I kill Firefox, the CPU usage still remains at 100%, so I don't think it's Firefox causing this. I tried restarting a few times but that didn't help either. My development experience has been very bad for last two days.

I not aware of anything particular that I did which may have caused this problem. I applied a few system updates as they became available in the last few days.

What procedure should I follow to find out what is causing this 100% CPU usage constantly for two days? Or if you already know the problem, please suggest.


The problem is related to Gnome and not Firefox or Compiz. Here is a screen-shot of "htop" with compiz, Firefox and almost all of the usual system-tray programs killed. You can see, it is still at 100%, but apparently no program is eating that much resource. The CPU temperature reaches 90 degrees after some time.

I am now using XFCE and everything is great.

Failsafe Gnome also does NOT solve the problem. Failsafe terminal DOES. Any ideas what is causing this?

enter image description here

share|improve this question

migrated from Aug 12 '09 at 18:00

This question came from our site for system and network administrators.

it's more suited for ; run shell and in it command called top. on the top of process list you'll see what takes most cpu time. – pQd Aug 12 '09 at 7:38
He already did that. htop beats top any time and gnome-system-monitor should also do the job. – innaM Aug 12 '09 at 8:06
By the way: this question should better be asked on – innaM Aug 12 '09 at 8:07
Thank you guys for taking time to comment. I went to But it says its in beta. They want a beta access password that I have no idea where to get. – vulcan_hacker Aug 12 '09 at 8:30
Take a look at this:… – innaM Aug 12 '09 at 8:48
up vote 1 down vote accepted

Try bumping to Karmic now that it's out. The intel video regression has been fixed.

Since I can't read: You're using ATi card right? Is this flgrx or the ati driver? If you didn't install anything and didn't choose the proprietary driver, the answer is ati.

Try bumping to Karmic anyway; you may want to do a clean install. If it's worse or the same as Jaunty, roll back to Intrepid or try another distribution.

(Not that Karmic doesn't have its own issues.)

share|improve this answer
that particular issue ("intel video regression") isn't the problem; OP stated in a comment his laptop uses an ATI Radeon Xpress chip. – quack quixote Nov 25 '09 at 18:35
Thanks for the answers and the comments. I am using Karmic since beta, the CPU usage behaving OK now. But I haven't installed many things yet. So not sure that problem is gone for ever. Hopefully it is. – vulcan_hacker Dec 5 '09 at 21:31

Most likely you are using a laptop with Intel onboard graphic chipset. There is a bug that results in this performance issue you describe. Here is an article detailing the issue but I am afraid there is still no official fix just some workarounds.

share|improve this answer
Hi OliverS, Thanks for your answer. I am using the computer with ubuntu for two years (Jaunty from the release date). Its an Asus with ATI Raedon Xpress graphics card. It did not do anything like that before. So that is not the case here. What would you do if your laptop suddenly started doing this to you. That sort of tip will be mighty helpful. Thanks again. – vulcan_hacker Aug 12 '09 at 11:06

disable effects and see if that alters anything with behavior...?

disable addons for firefox, see if something on that is triggering the behavior?

Sometimes I end up renaming ~/.mozilla to ~/.mozilla.bak and see if a fresh slate makes Firefox behave. I've had a lot of situations on Linux where Firefox starts acting up (usually with playing flash videos on YouTube) where I end up doing this and a lot of wonky behavior goes away.

Export your bookmarks first, though, so you can re-import them.

share|improve this answer
You can run "firefox -safe-mode" from a command prompt to temporarily disable your firefox extensions and themes. – 3dinfluence Aug 12 '09 at 13:54
The problem stays with firefox not running. You can use the FlashBlock addon with firefox. Then your overall cpu usage will not be high all the time. And you can see flash videos or flash elements when you want. You can also set filters to let the flash enabled for a few sites. – vulcan_hacker Aug 13 '09 at 3:10

I'm just guessing but maybe it helps: happen to me sometime ago, udev was causing cpu usage goes to 100%. I killed udevd and cpu usage went to normal.

share|improve this answer
I tried that. Did not help :(. – vulcan_hacker Aug 13 '09 at 3:11

If your system was working fine earlier, and the only system-wide changes have been updates, then the fault almost certainly lies with the updated packages.

A few avenues to investigate:

  1. Do you install proposed updates? (Check Administration->Software Sources->Updates tab)
  2. Do you have PPAs in your repository that include xorg- drivers or firefox?
  3. Did the xorg package get updated around the time you noticed this problem?
  4. Did the firefox package get updated around this time?

I'd try to revert back all (or atleast the above two) packages that were updated since around the time you first noticed this problem. If the issue goes away, upgrade one package at a time.

I'm not certain here, but I think there have been other problems with the xorg- drivers on Jaunty, especially when used in combination with compiz.

Also, did the system updates happen through Update Manager? If you did, you could look up the package install history from System->Administration->Synaptic Package Manager and in the app: File menu->History. If not, then you'd have to use the less user-friendly /var/log/dpkg.log file contents.

$ sudo tail -5 /var/log/dpkg.log
2009-08-12 12:44:18 status half-configured libc6 2.9-4ubuntu6
2009-08-12 12:44:20 status installed libc6 2.9-4ubuntu6
2009-08-12 12:44:20 trigproc python-support 0.8.7ubuntu4 0.8.7ubuntu4
2009-08-12 12:44:20 status half-configured python-support 0.8.7ubuntu4
2009-08-12 12:44:20 status installed python-support 0.8.7ubuntu4

Edit: A question I posted a couple of days back that might be of help in reverting back the packages - How do I revert to an alternate version of a package on Ubuntu?

share|improve this answer
1. Yes 2. Yes 3. "sudo tail -2000 /var/log/dpkg.log | grep xorg" => returns nothing. 4. Yes, but with no firefox running the CPU stays at 100%. So firefox cannot be the reason. – vulcan_hacker Aug 13 '09 at 3:21
Also with Compiz turndes off, the problem persists. – vulcan_hacker Aug 13 '09 at 3:22
You should probably then look at the dpkg.log output for the affected date range and go over the list of updated packages. Also turn off proposed updates and the PPA that contains xorg- drivers - these are more bleeding edge and hence less stable. – nagul Aug 13 '09 at 7:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .