Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My home network consists of a cable modem provided by the ISP, which is connected to a switch, from the switch 1 cable runs to the digital tv decoder/recorder also provided by my ISP and another cable goes into the WAN port of my router. ALL other computers are attached to the router with NAT, DHCP. The sole reason of the switch between the modem and the router is that the digital tv decoder/recorder needs a public ip to function, it doesn't work behind NAT, even with all ports forwarded...

The whole setup looks like this:

 [isp] (dhcp)
   |
 [modem]
   |  
 [switch]
   |  
   +--[digital tv]
   |  
   +-- (wan port) -- [router] (dhcp)
                       |
                       +--[pc]
                       |
                       +--[pc]
                       |
                       +--[pc]

The issue with this setup is that when clients attached to the router are configured as dhcp clients, they sometimes get an ip from the router's dhcp server in the NAT domain, as desired, but sometimes they get a public ip from the modem depending on which dhcp server, the modem's or the router's, reponds first.

The modem seems to hand out 2 ip's in the public domain 84.xxx.xxx.xxx and this functionality can not be disabled as far as I know. This is not desired because other computers which are behind NAT are unreachable in this case.

Currently I give the clients attached to the router a static ip in the NAT domain as a workaround, but I am looking for a solution so that clients would always get an ip address from the router's dhcp server if they are configured as dhcp clients.

Is this possible??

share|improve this question
2  
Something's not right here. The router should never forward the dhcp request to the modem. –  Martin Dec 6 '10 at 13:04
    
So I guess something like "How to favour my router's DHCP over my modem's DHCP?" better summarizes your question? –  Arjan Dec 6 '10 at 13:06
1  
That shouldn't be possible if your router is hooked up and working correctly. The PC's on the router should not see the DHCP from the cable modem. It sounds like the router is acting as a switch. What model is the router? –  shf301 Dec 6 '10 at 13:08
1  
@Arjan: no, outside dhcp should not be allowed in the intranet. an outside dhcp server must not configure anything in that private network. it's not "favour this over that", it's "disable that completely for the intranet". –  akira Dec 6 '10 at 13:09
2  
@akira and nkr1pt, any wording is fine with me, if it's better than just "home network question regarding dhcp". How is that title a question? (And akira, thanks for a great edit!) –  Arjan Dec 6 '10 at 13:40

2 Answers 2

It sounds like your router isn't working correctly as is, unless thats a "feature" included with it.

I'd log into the router and check out the configuration for the DHCP pool. While you're in there look for a setting called IP Passthrough and disable it.

share|improve this answer

firewall/block dhcp-packets from the external net towards your internal net.

that should allow your router to get a valid ip via dhcp for itself, but should stop your intranet clients to talk to the outside.

strange enough that your "router" behaves like you described already, because it is very uncommon to push dhcp-requests to the outside world and then hand back an answer to internal clients.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.