Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a backup.list file that looks like this:

+ /ext/installs
+ /ext/media
- /ext
- /backup
- /dev
- /mnt
- /proc

/ext is a symlink to /mnt/vg1/vol1, under which are installs and media directories.

I'm running:

rdiff-backup --backup-mode --include-globbing-filelist backup.list / /backup

rdiff-backup keeps recreating a symlink: /backup/ext -> /mnt/vg1/vol1, which is kind of missing the point, because then it doesn't actually back up the files in /mnt/vg1/vol1/installs, etc.

What am I doing wrong?

share|improve this question
up vote 1 down vote accepted

You're not doing anything wrong. This is how rdiff-backup behaves. It copies the symlink file, not the contents it points to, by design. If you want /mnt/vg1/vol1 to be backed up you have to add it to your backup.list file or tell rdiff-backup about it using the --include option.

share|improve this answer
    
The problem with that is that /ext already moved once (from /mnt/vg0/vol1). I wanted to use symlinks to hide this from everyone (including rdiff-backup). If I --include it by fully-qualifying the paths, I'll end up with two copies of the source files (one new, pristine; one old, under increments). – Roger Lipscombe Dec 6 '10 at 16:00
    
Wish I had a better answer for you but: that's life with rsdiff-backup. Instead of making /ext a symlink, could you not mount /mnt/vg0/vol1 at /ext? That would solve the problem. – Ian C. Dec 6 '10 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .