Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did a horrible mistake about 2 days ago; I was thinking of cleaning up my PC, so I thought of emptying the user profiles' folders. There were also some users whose accounts I'd already deleted, so I thought about completely deleting their folders.

However it seems that while doing so, the Default profiles and all others except the one on which I was logged on got deleted.

So now, I don't have libraries anymore, can't even create them, I can't login with other users (from the domain); it tells me "The User Profile Service failed the logon. User profile cannot be loaded.".

So does anyone has an idea of how I can correct this?

share|improve this question
    
Did you delete the C:\users\default folder? –  Moab Dec 6 '10 at 17:46
    
Yes, it did get deleted automatically from the folder when I deleted other profiles; that's something I don't understand how it happened!! The only folder remaining in Users\ is mine.. –  Yusuf Dec 7 '10 at 14:25
    
Did you try a system restore as suggested below? You may have to back up your data and reinstall. –  Moab Dec 7 '10 at 15:35
    
I tried system restore; didn't work.. –  Yusuf Dec 8 '10 at 8:34

2 Answers 2

up vote 5 down vote accepted

First Try a Microsoft System Restore, Boot from a Windows 7 install disc and select "repair your computer", then select "System Restore", pick a date before you deleted the folders, see link below on how to boot from the W7 disc.

If this does not work move to the next solution

Use a W7 install disc and boot from it to get the recovery environment, then use the command prompt to attempt to enable the hidden admin account, hit enter after each these 2 commands.

C:

net user administrator /active:yes

.

How to get to the command prompt from a W7 disc. This is for Vista but is the same using a W7 disc. http://www.bleepingcomputer.com/tutorials/tutorial147.html

After you enable the admin account restart and see if you get a new admin icon, see if you can log into that account, if you can create a new user account in control panel for another way to log in. You don't want to use the new admin account for everyday use. If you get it repaired you can disable that account by using the following command while in Windows

net user administrator /active:no

If you still get the error and you did delete the C:\users\default folder, you will have to get a copy of that folder from another windows 7 PC and copy it back where it belongs, use an Ubuntu boot CD to do this, the link below is for backing up data, but it could be used to copy a folder to the hard drive also.

http://www.howtogeek.com/howto/windows-vista/use-ubuntu-live-cd-to-backup-files-from-your-dead-windows-computer/

.

**NOTE: you need to use a regular Windows 7 install dvd, a "recovery" DVD from some PC manufacturers (HP etc.) will not work, if you do not have one you can download the proper ISO file from this link, then burn it to DVD as an Image (not data). Be sure to pick the proper version (Home,Pro etc) and bit (32 or 64)

http://www.mydigitallife.info/2010/04/28/download-windows-7-iso-official-32-bit-and-64-bit-direct-download-links/

.

.

share|improve this answer
    
I tried System restore, didn't work. I can login from the Administrator account, it tells me that a profile service cannot find a folder or something like that, and that any changes I make to the profile will be lost when I log off. I can create another user, but I cannot login with it. Wait, it's only now that I've seen the easiest solution from your answer: Copying the folder from another PC!! I'll try that this evening when I get home and let you know!! –  Yusuf Dec 8 '10 at 8:35
    
Don't copy the user folders, just the "default" folder, see if it gets it working. –  Moab Dec 8 '10 at 15:19
    
Ok, I think that logging in with the Administrator yesterday worked, but since I got some bizarre messages, I had thought that it was not really working, so I did not bother logging in with another user; however, I logged in today with another user, and it seems to be OK.. but I already copied over the Default folder.. Do I leave it? :S –  Yusuf Dec 8 '10 at 19:08
    
Yes, there needs to be a default user folder. –  Moab Dec 8 '10 at 22:43
  • Open up the Registry editor
  • Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  • Under that key delete the key for every profile you deleted. Look at the ProfileImagePath value under each key to determine which keys need to be deleted. The keys will be named something like HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-21-3050247859-2755525454-1526568157-1000

A comment from a Microsoft Support on this thread says:

A profile that is manually deleted does not remove the security identifier (SID) from the profile list in the registry.

If the SID is present, Windows will try to load the profile by using the ProfileImagePath that points to a nonexistent path. Therefore, the profile cannot be loaded.

Also see kb947215.

share|improve this answer
    
I tried the steps you listed; still did not work; I'm going to check the links.. –  Yusuf Dec 7 '10 at 14:26
    
kb947215 not applicable for me.. –  Yusuf Dec 7 '10 at 14:28
    
nothing's working; I don't think I have a recent system restore point, but if that's the only remaining solution, I'll have to go for it! –  Yusuf Dec 7 '10 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.