Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some time ago my Chrome started to open PDFs in Google Docs viewer. I don't really know if I did something to force this behaviour, but I would like to view it as I was before (using Foxit Reader plugin).

Every link to a pdf file is replaced by Chrome: https://docs.google.com/viewer?url=http://url.of.the.pdf

Have googled a bit but I can't find how to disable this 'feature'.

share|improve this question
3  
Are you sure you're not using any extension to do this ? –  Sathya Dec 6 '10 at 19:06

6 Answers 6

up vote 5 down vote accepted

To disable Chrome from automatically using the Google Reader, go to "chrome://plugins/". Then locate and disable the plugin called "Chrome PDF Viewer". When this was installed, it should have automatically disabled your previous reader, (mine happend to be Adobe Acrobat, but this should work anyway). Then find your Foxit Reader Plugin entry, and re-enable that. Should work as soon as you load a PDF. You might want to restart Chrome to make sure, but for me it worked simply with a new tab.

share|improve this answer
1  
Didn't work. I've disabled it the "Chrome PDF Viewer" and re-enable the Foxit plugin, but Chrome is still changing the links to pdf to docs.google.com/viewer... Tried restarting chrome and opening a new tab =( –  emzero Dec 6 '10 at 20:04
    
Ok, question: Are you looking at PDF's that are hosted on Google Docs? If so, they will automatically open in Google Docs. Also, where did you get a port of Foxit Reader? I can't seem to find it on the Extensions website. –  blackmastiff Dec 6 '10 at 20:19
1  
Seems like Chrome sneaks into Firefox plugins dir: google.com/support/forum/p/Chrome/… And no, I'm not reading a PDF hosted on google docs. Anyway, this thing doesn't want to be disabled =/ –  emzero Dec 6 '10 at 20:49
    
OK, what I did to make it work for me was to go to the Foxit site, and download the newest version (4.3 I think). Anyway, once I had installed that, I grabbed the FoxitReaderOCX.ocx, and did the bit copying it to Sys32. Once I ran the command prompt line "regsvr32 FoxitReaderOCX.ocx", it was golden. Now, I am not positive that this will work for you, because I installed Foxit reader after the latest version of chrome, but try redoing the cmd line step, and don't worry about "npFoxitReader.dll" at all. –  blackmastiff Dec 7 '10 at 0:52
    
I want Acrobat, not Google Chrome viewer. I have Chrome PDF Viewer disabled and Adobe Acrobat enabled: i.imgur.com/Bqt3m.png. A test PDF loads in Acrobat (education.gov.yk.ca/pdf/pdf-test.pdf) but any PDF file within Google Docs loads in the viewer only. Any ideas for this? –  Robert Mark Bram Jul 25 '12 at 0:46

If you are using Chrome as your browser, click on the Toolbar (wrench) in the upper-right corner, click "Tools," click "Extensions," and you should see the "Docs PDF/PowerPoint Viewer (by Google)" extension. If you do not find the "Extensions" in the menu, type chrome://chrome/extensions/ to the address bar.

To disable the viewer, simply click on the "Options" link. This will give you the option to check or uncheck the type of file you want Reader to handle (e.g., doc, docx, pdf, pps, tif, tiff). You can also type in domains (e.g., sites.google.com) that you want exempted from the viewer tool.

This worked for me without any problem.

Good luck!

share|improve this answer
1  
Unfortunately I don't have that extension listed in the extensions list =/ –  emzero Jan 26 '11 at 4:17

Answer: No. The "View" button under Gmail file attachment uses Google Docs viewer. This is because the "View" button was specifically programmed by Google to use Google Docs viewer. (You can see how this would help promote Google Docs as a product). As of now there is no way to change this behavior. If it could be changed, it would be changed at the Gmail settings level which would say something like "Change default behavior of file attachment View button".

(From Google article) "Google Docs is also connected directly to Gmail. If you receive an attachment in Gmail, you can click the ‘View’ link, which will display that file attachment in the Google Docs."

Article from Google called: "View files in Google Docs" http://support.google.com/docs/bin/answer.py?hl=en&answer=1738646

share|improve this answer

It is a plug-in and needs to be disabled (but stupid Google doesn't include an easy button to click to get to plug-ins).

From Google:

To disable the built-in viewer, enter chrome:plugins in the address bar and click Disable underneath the entry for “Chrome PDF Viewer.” The Adobe Reader plug-in will automatically be enabled, if you have it installed.

https://support.google.com/chrome/answer/1060734?hl=en

share|improve this answer

Have you checked your extensions page to make sure you don't have anything that might do that? (To be totally sure, you should try disabling everything and reload a page with a PDF link.)

I can't say I've ever seen this, but then again I can't say I've ever tried Chrome on a system without Adobe [Acrobat] Reader installed already... what I can say is that my Chrome recently started opening PDFs with some new thing that seemed to be part of Chrome, though it was listed in the plugin list and could be disabled there, and that disabling both it and Adobe's plugin made Chrome do its "must download to download directory before opening" thing...

share|improve this answer
  1. go to chrome://extensions
  2. Find "Docs PDF/PowerPoint Viewer (by Google)"
  3. Uncheck "enable" or click the trash icon.

The Chrome PDF viewer plugin mentioned by blackmastiff actually comes with chrome and simply displays the file as is. It is not integrated with google drive/docs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.