Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have office 2010 installed and the file was working but suddenly when I try to open it It gives me following error

Excel cannot open the file ... because the file format or the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file.

also I tried a program to repair it.

What can I do?

share|improve this question
Is it an XLSX or XLS file? Did you save it as a different file format? – Rhys Gibson Dec 7 '10 at 1:19
which program? upload the file (if u can). – gadgetmo Jan 30 '12 at 18:19

Change the file extension manually from .xlsx to .xls and try again.

share|improve this answer

I ran into a similar problem when going from Office 2003 to Office 2007. To fix this, edit your registry.

For Office 2007:

Windows Registry Editor Version 5.00


For Office 2010:

Windows Registry Editor Version 5.00


You can either manually make the above entries or copy and paste the text into Notepad and save it using the ".reg" extension. If you want to make a reg file make sure you leave a space between the first line, "Windows Registry Editor Version 5.00", and the next line, and place a space after the last line.

To save your reg file, go to File > Save As, browse to the place you want to save it and when you give it the name, enclose the name in quotes; e.g. "ExcelExtensionHardening.reg". Make sure to do all this in Notepad, not Word, WordPad, etc, as those programs will add things that make the reg file useless, and could possiblly hose your entire OS.

To apply your reg file, just double-click it.

share|improve this answer
  1. Open Excel, and click on the Microsoft Icon at the top left.

  2. In the window at the bottom is "Excel Options". Click it.

  3. Then select "Advanced" on the left side of the screen.

  4. When the display comes up, you need to scroll almost to the bottom.

  5. Under the blue "General" category, will be "Ignore other applications that use Dynamic Data Exchange " Make sure it is not checked.

  6. Then Test it and see whether it works

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.