Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use putty to ssh to linux box. By default I get black screen background with white foreground. To change colours, I go to change settings -> Window/colours and then I set background colours as white and foreground colours as black. This is more easy on my eyes. But I can't seem to be able to set this colour setting as default and each time I login, I have to set colours. Could someone please suggest a solution?

Thanks,

share|improve this question

migrated from stackoverflow.com Dec 7 '10 at 1:15

This question came from our site for professional and enthusiast programmers.

    
question for "superuser" – Drakosha Dec 6 '10 at 9:42
up vote 33 down vote accepted

On the "Session" screen, click "Default Settings" and "Load". Then set up your Colors and other useful Options. Go back to the "Session" screen, click "Default Settings" once and then "Save".

All new connection windows will now look as expected.

share|improve this answer
1  
Important note is, that as mentioned it only works for new connections. Existing ones will stay as the were before the change. – Christian Woerz Dec 28 '15 at 16:52

The above instructions will only change colors for the default session. Most PuTTY users have saved sessions for each of the SSH accounts that they use regularly, and none of them are named "Default Settings".

To spare yourself the pain of having to set the colors every time you log in, load any of the saved sessions for which you wish to change the colors (click Load), but do not click Open. Click Window->Colours and set the colors, then click Session again, then click Save. Repeat for each of your saved sessions. Then when you open them, the colors will be what you have set them to be.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .