Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Not sure if this is the right place to ask this but I forgot the username and password to my comcast/netgear router. I went to and got to a login screen. I used "admin" for the username and "password" for the credentials. When that didn't work, I pressed the little reset button (the one you need a paperclip to press).

i've also tried admin/admin, admin/1234, [blank]/admin, [blank]/[blank] to no avail.

How can I retrieve the password or fully reset the router?

share|improve this question
up vote 3 down vote accepted

It's worth trying 1234 or "admin" as the password, but if that doesn't work and you're comfortable losing ALL the settings on the router (including such things as the credentials you need to access the internet), do the following:

1) Unplug the power 2) Press and hold the reset button 3) While holding the reset button, reconnect the power. 4) Continue to hold the reset button for 20 more seconds 5) Wait for router to reboot

Then you can login with admin/password or admin/1234

share|improve this answer
that didn't seem to do the trick. I got logged out but the same network (WPA) password still worked. – Ramy Dec 7 '10 at 4:40
What is the model number of the router? – geodave Dec 7 '10 at 4:46
WGR614v8 is the only thing I can find. I see a serial number, a serial PIN and a mac number on the back. Also, it says the default credentials are admin/password. (which is not working.) – Ramy Dec 7 '10 at 14:06
The manual for that specific model of router says that to restore the default original settings, including the password (it resets back to "password") you hold the "restore settings button" on the back panel for 10 seconds and let go, then wait for it to reboot. – geodave Dec 7 '10 at 18:39

Did you try comcast/1234? That's supposed to be the default for Comcast gateway devices.

share|improve this answer
this also fails – Ramy Dec 7 '10 at 14:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .