Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(I'm on Mac OS X 10.6.5, though I just upgraded from 10.5 maybe a month ago.)

Since time out of mind, I have been able to copy a screenshot selection to the clipboard (using cmd+ctrl+shift+4), and paste it into a new or existing Photoshop (CS3) file, and then use, say the magic wand to find a contiguous area of color. As of a few days ago, this stopped working so well. The pasted image appears to be dithered. See here:

enter image description here

The region on the left should be solid #FF00FF. In fact, if I do a cmd+shift+4 (which just creates a file, doesn't copy anything to the clipboard), and open that in Photoshop, it works properly. I can also paste from the clipboard into another application such as Acorn and verify that the color is solid. (So, this seems to be a Photoshop issue.)

The only solution I've come to is that if, when pasting into a new document, I choose 16 bit color mode (it defaults to 8 bit), then I don't get the dithering. However, I have never had to do this before. It's always just worked. Is this something that may have changed in Snow Leopard and I'm only just now noticing it? Any other ideas of what may be going wrong?

share|improve this question
    
For what it's worth, I also noticed that when I do a screen capture to clipboard of the entire window, the drop shadow is completely opaque. (I know there is an option to remove the drop shadow, but I don't want to do that.) Also, both symptoms only seem to happen in Photoshop. Pasting that screenshot into Preview shows the correct dropshadow. So weird, like Photoshop is converting it into an 8-bit PNG. –  shanebonham Dec 11 '10 at 20:09
    
Maybe screenshots became 16-bit in Snow Leopard? I honestly have no idea, just throwing that out there. –  Sasha Chedygov Jan 20 '11 at 4:03
add comment

2 Answers

up vote 1 down vote accepted

I had this same issue and I think I was able to fix it.
I went to Edit > Color Settings... > Color Management Policies and then set RGB to Off You can also check Ask When Pasting instead and select Don't Convert each time you paste.

share|improve this answer
    
Thanks! I'm marking this as the accepted answer. (Note that it doesn't solve the drop shadow issue I referenced in my comment to my question, but that was a minor issue compared to the color problems.) –  shanebonham Feb 1 '13 at 16:54
add comment

When taking a screen capture like that it uses Quicktime to compress and decompress the low rez grab. Try using the Grab application for a truer image. Save the resulting tiff and then open it in Photoshop. It takes a few seconds longer but seems to work a lot better for me.

share|improve this answer
1  
I'm able to get it working if I change the color depth of the new Photoshop file, or if I just save the screen grab to a file and then open, both of which are probably quicker than using Grab... I'm trying to figure out how to get back to what I had before, or at least figure out why it changed. –  shanebonham Dec 7 '10 at 20:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.