Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I spend quite a lot of time working on various machines via RDP (usually RDPing to one machine and from there RDPing to other computers outside our LAN) and have an issue where the modifier keys (i.e., Ctrl, Alt, Shift, and Windows Key Win) sometimes don't take effect as quickly as standard keystrokes.

For example, if I am trying to type "", I could end up getting 2" because the remote machine gets the first press of the 2 key before it gets the Shift modifier. This causes particular problems with password protected fields (as they often require mixed case letters and you can not see what is typed) and with Ctrl+C (where the highlighted section is deleted and replaced with a C).

(And before anyone asks, this is not just bad typing, otherwise the problem would not be restricted to RDP sessions.)

This does not appear to be a hardware issue as it happens on my desktop (running 64-bit Windows 7) and on my laptop (32-bit XP) and on various Remote computers running various operating systems (from XP to Windows 2008 Server)

There are times when the problem is more pronounced, and it may be related to a slow Internet/VPN connection.

Has anyone seen this problem, and (other than always typing very very slowly, i.e., about one character per second) are there any solutions to this issue?

share|improve this question
I very often experience this - both lack of synch, and a control key getting 'stuck' - specifically, Shift. Then I started getting CAPITALIZED TEXT TYPED IN or issuing commands I did not wish to issue. – einpoklum Sep 11 '13 at 18:11
I would user a bounty on this question if I had more reputation on SU... would be very glad if you decided it's worth risking the 50 points. – einpoklum Nov 13 '13 at 16:12
I use RDP a lot and never experienced that. What utilities do you have running on your systems? Does it have something like AutoHotKey? What version of RDP? Does it always happens? Have you trying using the machine locally just to be sure it is not something RDP-related? – Luiz Angelo Dec 22 '13 at 19:27
Do you have IntelliType installed?… – Luiz Angelo Dec 22 '13 at 19:50

It is the way the RDP client responds to control keys. To resolve, try going into the options for the Remote Desktop Connection, Local Resources, Keyboard - change to "On This Computer".

Be aware that alt-Tab and similar commands will now run on the local system.

share|improve this answer
Tried that, but it did not help. (It did mean that the alt-tab did not work on the remote computer, so the setting was in effect) – sgmoore Dec 17 '10 at 17:53
I second @sgmoore's report: Restricting key combinations to the local computer does not avoid this problem. – einpoklum Nov 15 '13 at 19:10
The RDP Keyboard "On This Computer" setting was the only thing that successfully resolved the annoying issue for me. To replace the alt-Tab on the target machine, I'm using, which is an open-source project on GitHub. I find it even better than the original Win7 alt-Tab dialog. – V-R Dec 30 '15 at 11:42

It's not "free" but some gamepads let you map buttons to key combinations...think out there mouse or numpad with wrist pivots(i think asus makes one). this MIGHT solve you problem....not 100%, but if it sends a combination it could. the slowing down of modifier keys could also be a cheap attempt at not passing on control sequences(if this turns out to be the case i would look in to VNC server/client as it's a busted solution)

share|improve this answer
Don't think this will help unless the gamepad has keys for every single key-combination, eg a key for 'a', another for 'A', another for Ctrl-A, another for Alt-A etc. Also I've used VNC in the past, always tried to replace it with RD or Logmein where possible. – sgmoore Dec 10 '10 at 9:17
true enough, I didn't know if you were stalling on a single key combo or a bunch of them – RobotHumans Dec 10 '10 at 11:06

I've found the solution to this where one is using nested instances of Microsoft's Remote Desktop client. Imagine the following situation. You're sitting in front of an OS X machine, and you remote desktop into a Windows 7 laptop. From the Windows laptop you want to remote desktop into another Windows machine (in my case a work box over VPN). The solution to your keyboard mapping woes is: on the Windows laptop, i.e. the destination of the first jump, change the remote desktop hardware settings for the 2nd jump to use the local keyboard, not the connecting one.


To change the setting:

  1. Open de Remote Desktop Client.
  2. Do not connect to a remote host, yet.
  3. Click button Options.
  4. Open tab Local Resources.
  5. Choose option "On this computer" in drop-down list de Apply Windows key combinations.

Although this setting does not seem to apply to simple Shift-key combinations, it did solve the problem for me, when working with nested remote desktops.

Of course, it comes at a price: you cannot Alt-Tab through the windows on the remote host, etc.

share|improve this answer
Where exactly do you change the 'remote desktop hardware settings'? – sgmoore Sep 14 '11 at 17:31
I don't think the OP asked about nested RDP sessions. – einpoklum Sep 11 '13 at 18:10
This doesn't work - see the comments on this answer – einpoklum Nov 15 '13 at 19:11

Some more workarounds :

  1. Run Remote Desktop as Administrator.
  2. Uninstall IntelliType if installed. You may use instead X-Mouse Button Control.
  3. Disable TCP Auto Tuning.
  4. Reduce color depth / resolution / background.
  5. Disable any keyboard product such as AutoHotKey.
  6. Fully patch Windows Update including all optional items.
share|improve this answer
1. Will Try and see if the problem manifests; what's the intiuition for such a measure having an effect? 2. If IntelliType does not appear in the Programs list (for uninistallation), might it still be installed? 3. My Windows 7 is fully-patched. – einpoklum Dec 19 '13 at 11:58
2. Probably not. – harrymc Dec 19 '13 at 12:42
I'm not immediately seeing the problem manifest, but as it doesn't always occur immediately we'll go into extended trial... why do you think running the RDP client as Administrator helps? Especially for a user who is an Administrator? – einpoklum Dec 19 '13 at 16:22
A security feature since Vista : Everyone runs under a restricted account, only "Run as Administrator" is unrestricted. – harrymc Dec 19 '13 at 17:01
Unfortunately, this did not work - although it seems the frequency of the 'sticky shift' phenomenon decreases when RunAs'ing as Administrator. Or perhaps I'm just not performing enough repetitions of the experiment. Anyway, no cigar. – einpoklum Dec 22 '13 at 23:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.