Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i tried using Meld as external diff in KdeSVN as meld -on - (settings>configure kdesvn>diff&merge) but Meld complains that the usage is wrong:

meld: error: no such option: -o

Finished
Usage: 
  meld                        Start with an empty window
  meld <file|dir>             Start a version control comparison
  meld <file> <file> [<file>] Start a 2- or 3-way file comparison
  meld <dir> <dir> [<dir>]    Start a 2- or 3-way directory comparison
  meld <file> <dir>           Start a comparison between file and dir/file

i have no idea what parameters that i should use, could someone give me the correct command?

share|improve this question
    
i tried meld %f %f but -as expected- it compares the selected file to itself. –  sterz Dec 9 '10 at 21:37

2 Answers 2

up vote 7 down vote accepted

The right solution for this problem is: meld %1 %2

share|improve this answer
    
%1 and %2 don't appear to be valid operators as Meld simply tries to open those strings as files. Perhaps kdesvn has changed the parameter types? –  Paul Lammertsma Jan 27 '14 at 11:58

I was experiencing a similar problem after altering this setting.

In the history-window, I was double-clicking on the modified files in the bottom-right-hand pane, assuming that would give me the diff.

Instead, kdesvn opened a window containing the text of the file.

I've now realised my mistake:

  • double-clicking = "annotate" action

In order to diff, you need to right-click the file, and select "Diff previous" in the context menu.

Thought I'd better share, in-case anyone else new to kdesvn makes the same wrong assumption.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.