Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After using a USB flash drive or memory card on my laptop (Win XP SP2) I get the following dialog saying:

There is no disk in the drive. Please insert a disk into drive .

Notice the space between the last letter and full stop. That has to be a placeholder probably for something like a drive letter but it's empty.

enter image description here

This will never leave. Whenever I press anything on this dialog, it will come up after a couple of seconds so I just drag it outside of the screen. It will only go away if I reboot. A serious problem is that the existence of this dialog blocks the startup of some programs, for example mspaint.

I've tried rearranging the drive letters for removable media via Disk Management but no luck.

This has been happening for the last six months.

Any ideas?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

What is the letter of the drive for the removable media? While probably not exact to your case, KB330137 suggests possibility of this error message if the removable drive is actually C:

For me, my computers don't have floppy disk drives anymore, so I actually assign A: B: to my thumb drives and card readers. You may want to try that if you haven't done so.

share|improve this answer
    
E: and F: and I've changed them to L: and M: without any change. I'll try assigning them to A: and B: and let you know if this works. –  cherouvim Dec 8 '10 at 11:47
    
Assigning them to A: and B: magically solved the problem! Awesome! –  cherouvim Dec 10 '10 at 6:40

You started some application from that drive and it is still running OR has files open on that disk.

Always use 'Saftely remove' function before ejecting drive from your computer

share|improve this answer
    
This has been happening for the last 12 months and I've rebooted hundreds of times since then. The popup starts when I use any USB drive. It's now fixed though using icelava's answer. Thanks. –  cherouvim Dec 15 '10 at 4:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.