Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I was really excited about the new integrated pdf viewer in chrome. However when I click on a pdf file link, chrome offers to download it instead of opening it inside its viewer.

How do i get it to open pdfs inside its viewer?

Edit: I have found that it behaves kinda randomly. Sometimes it does open it inside its viewer and sometimes it asks to download it.

In gmail though it always asks to download it.

Note: I already have the 'ask where to save each file before downloading' option unchecked.

share|improve this question
    
Do the reverse of this - superuser.com/questions/107700/… –  ChrisF Dec 8 '10 at 20:47
    
possible duplicate of Make Chrome always open PDFs itself –  ks1322 Aug 24 '13 at 13:16
add comment

5 Answers

The behavior of Chrome (and other browsers) depends on the "content-disposition" HTTP header. If it is set to "inline", it will auto-open if configured accordingly. If it is set to "attachment", Chrome will offer to save it, regardless of other configurations. In other words, behavior will vary from site to site, just like you're describing. I don't know, however, if and how it could be made to open the PDF in any case; I'm afraid this might not be possible.

share|improve this answer
add comment

I think that the problem sometimes occurs when the web server you are downloading the PDF from does not serve the PDF with the correct MIME type.

When the web server serves a PDF with the correct MIME type, Chrome previews it. When the web server serves a PDF with the incorrect or generic MIME type (application/octet-stream), Chrome downloads it.

If the server returns a Content-Type of text/html Chrome will display/open the PDF directly in the browser. However, if the server returns a Content-Type of application/pdf then the browser will prompt the user to save/download the PDF.

share|improve this answer
    
Yep, content-disposition inline ain't enough, it also needs mime application/pdf. –  Quandary Feb 25 at 9:10
add comment

I did the always open option, and it does open it now, but it still downloads it. I suppose when pdf's open in IE they also download to the temp internet files directory. I don.t like the idea of changing the path for all the downloads to go to a Chromes temp directory though. It would be nice to just open pdf's without them being written to disk anywhere.

share|improve this answer
    
this is not really an answer , please try to restructure it –  Shakehar Mar 20 '12 at 15:43
add comment

The ability to auto-open PDFs was disabled in recent versions of Chrome. The developers re-implemented the feature and it is available again in Chrome 10 and above.

See this bug report for details.

share|improve this answer
add comment

Download a PDF file, then when it is done, left click on the download icon at the bottom and select "always open this type of file" Now It should open any PDF link you click in that window without downloading it to a permanent location.

To undo it go into Options>Under the Hood tab>Clear Auto Opening Settings.

I also have the box ticked, "ask where to save each file before download", not sure if this has any affect on the behavior of automatically opening a file.

There may be some PDFs that chrome cannot display properly, so it offers you to download it to view with another PDF viewer. It is not a full featured viewer like Foxit or Adobe

I use it this way and can find no PDF that chrome has saved, it has to cache it somewhere to read it, but I am not sure where it does.

Some more info on chrome hidden features http://www.blogsdna.com/828/seven-hidden-configuration-pages-of-google-chrome-browser.htm

Hidden experimental features for version 8

about:flags

.

share|improve this answer
    
I downloaded a pdf file, but 'the always open this type of file' option is disabled for it. –  pdeva Dec 8 '10 at 23:50
    
type "About:plugins" without the quotes into the url bar, hit enter, see if the Chrome pdf viewer is disabled, if it is, enable it, you may have to restart the browser. –  Moab Dec 8 '10 at 23:55
    
it is enabled. as i said, it does open pdf files randomly. –  pdeva Dec 9 '10 at 1:31
4  
This solution is incorrect. It causes files to still download, but then open immediately upon completion of the download. It does nothing to get Chrome's PDF viewer working. –  Noah Yetter May 13 '12 at 16:41
1  
Of course. That may excuse its incorrectness but it doesn't change it. –  Noah Yetter May 15 '12 at 19:56
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.