Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently made the move from Windows XP to Windows 7. Since then, when my computer is on for a few hours it always ends up rebooting without warning. Then the BIOS won't recognize my hard drive (hard drive 0 not found).

If I turn off my computer and then on again, it boots normally.

Some details:

  • Dell Dimension 9150
  • Windows 7
  • I updated the BIOS
  • I updated all system drivers with the latest version from Dell (SATA, Chipset, etc.)
  • Other drivers updated too (Graphic card, sound, etc.)

There is one thing that I tried after some Googling: I turned off the DMA access to the drives, but it's still rebooting after a few hours.

Any clue?

UPDATE 2010/12/13

Here are the events from the Event Log for today, from when I turned the computer on until it crashed:

19:17 - Error - ID 10016 - DistributedCom

20:06 - Error - ID 1008 - Customer Improvement Program (could not send data to Microsoft)

21:48 - Critical - ID 41 - Kernel-Power (System was restarted without proper shutdown)

21:48 - Error - ID 6008 - EventLog (Previous system down was not planned)

21:48 - Error - ID 1101 - EventLog (Audit Event ignored)

21:49 - Error - ID 10016 - DistributedCom

Both DistributedCom events have a description along these lines (translated from French):

The authorisation parameters specific to the application are not allowing Local Execeution for the COM server application with the CLSID {C97FCC79-E628-407D-AE68-A06AD6D8B4D1} and the APPID {344ED43D-D086-4961-86A6-1106F4ACAD9B} to the SID AUTHORITY NT\User System (S-1-5-18) from the address LocalHost (LRPC usage). This security authorisation can be changed with the Component service administration tool.

UPDATE 2010/12/31

Here are the error messages I have on blue screens : STOP C000007xA - Kernel_Data_Inpage_Error "Unkown hard error" C00000135 - Can't start because &hs is missing

share|improve this question
1  
Have you checked that the hard drive data and power cables are properly connected? –  ChrisF Dec 8 '10 at 21:46
    
have you checked the Windows event log to see why it is rebooting? –  Xantec Dec 8 '10 at 21:52
    
I'd swap it out and see if the problem persists –  Ciaran Dec 8 '10 at 22:03
    
I checked the data and power cables and they were connected properly. I swaped the data cables between my main and secondary drives to check if they are the cause of the problem. –  Danny T. Dec 14 '10 at 3:08
    
My computer crashes with any power or data cable attached... –  Danny T. Dec 31 '10 at 20:32

2 Answers 2

up vote 2 down vote accepted

Kernel_Data_Inpage_Error

indicates an error reloading memory that was paged (swapped out) to disk. I'd run a check on the hard disk; it sounds like you might have something failing there.

share|improve this answer
    
You were right! Every diagnostic I ran said the drive was okay, but I had a feeling this was a hard drive problem. So I bit the bullet and bought a new drive, installed Windows and everything and voilà! System stable. Bonus check: Latter I plugged in my old drive to transfer files and my computer crashed just like it did, with paging errors in event viewer. Turns out this old drive is dying. Thank you! –  Danny T. Jan 19 '11 at 11:51

Since that model is not officially supported by Dell for W7, it could be a bios bug that will never get fixed.

You could run hardware diagnostics on it, see if anything turns up.

Click Me

Latest drivers from Intel, install in this order, reboot after each.

Chipset 32 and 64 bit http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18494&ProdId=2115&lang=eng

Raid (IRST) 32 and 64 bit http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19607&ProdId=2115&lang=eng

Video 32bit http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18223&ProdId=2115&lang=eng

Video 64bit http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18228&ProdId=2115&lang=eng

.

Here is what Microsoft says about 7A errors

http://msdn.microsoft.com/en-us/library/ff559211(v=VS.85).aspx

.

share|improve this answer
    
Dell Diagnostics says everything is okay - thanks for the link. –  Danny T. Dec 13 '10 at 18:01
    
Replace the cmos battery, then immediately enter the bios and load defaults and set the date and time. –  Moab Dec 14 '10 at 2:58
    
Sorry, that didn't solve the problem –  Danny T. Dec 20 '10 at 13:13
    
I did an edit to my answer to include the latest Drivers from Intel. –  Moab Dec 20 '10 at 13:48
    
I installed the drivers and the situation is the same. I will get a new CMOS battery - I tried a reset and got a "low voltage" message at my first boot. –  Danny T. Dec 31 '10 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.