Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In notepad when I have a large file open, when I press save EVERY line feed is deleted and all compressed! Any suggestions?

share|improve this question
That doesn't sound likely. What kind of file is it? Where did this file come from? – Joel Spolsky Dec 9 '10 at 4:19
Downloaded from a filezilla FTP server. – James T Dec 9 '10 at 14:15

Choose File, Save As and note the encoding.

Use a Hex Dump tool to check the line endings - notepad expects CR LF but files from non-Windows sources, or files downloaded with incorrect FTP settings might have just CR or just LF.

Open the file in Wordpad instead.

share|improve this answer
Noooo! Wordpad is EVIL! It pretends to know vanilla ascii but prefers the RTF and DOC formats. Well, I suppose you could use Wordpad if you promise never to put the resultant file on the web. A better solution would involve obtaining one of the wonderful Windows based Notepad replacements (Notepad++,Notepad2, etc...) (Trying to be nice, I'm not a Windows user.) – lornix Sep 6 '11 at 5:12
up vote 0 down vote accepted

I figured it out, I had used a registry hack to enable the status bar AND word wrap at the same time, which bugged it. Disabling the hack fixed it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.