Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work Mac has Centrify installed on it; it's part of the office's enormous Active Directory system, has IT policies applied to it automatically, I can connect to SMB network shares without re-authenticating, etc. It seems to be working, except when I boot the machine and try to log in.

At the login screen, I can click the machine info a few times to see that "network accounts available" shows up with a nice green icon beside it. I enter my domain credentials, and a "wait" spinner shows up beside the password field.

The spinner stays there, effectively forever. I let it run for ~2-3 hours one day with no login, and no timeout.

If I boot with the network cable unplugged, I can log in no problem, presumably with cached AD credentials.

Any ideas?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

This definitely sounds like a timeout problem, could be that the machine can't find a Domain Controller to respond to the login request. We have improved DirectControl to do a much better job of finding Domain Controllers and timing out in a reasonable time as well as simply falling back to on cached login when all else fails. Updates to the Centrify DirectControl are free and should resolve this issue. Just have your IT give us a call or email me directly.

Thanks -David david.mcneely@centrify.com

share|improve this answer
    
Thanks David; I'll send you an email directly. –  chrish Dec 10 '10 at 14:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.