Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I connect to my Ubuntu box from any Mac OS X 10.6 client (Snow Leopard) using Nomachine, the 'd' key minimizes all windows on my Ubuntu box. I found another post here that says the issue can be fixed by changing some settings on the Ubuntu box when connected. However, I cannot find the location of the settings indicated in that post.

Does anyone know how to resolve this 'd' key problem?

share|improve this question

migrated from serverfault.com Dec 9 '10 at 15:12

This question came from our site for professional system and network administrators.

    
Please read our FAQ so you know what's appropriate for this site and what's more likely to be answered on our sister sites. –  Chopper3 Dec 9 '10 at 15:12
add comment

1 Answer 1

up vote 13 down vote accepted

By default Ubuntu maps the "show desktop" command to the Super+D key combination. The Super key is also sometimes known as the Windows key. While I've never used Nomachine, my assumption would be that it is having an issue with the Super key as it does not exist on your Mac. I would try changing that key binding on the Ubuntu side.

Go to System > Preferences > Keyboard Shortcuts

keyboard shortcuts

Find the entry titled "Hide all normal windows and set focus to the desktop" and try a new keyboard combination.

share|improve this answer
    
this fixed me when I was having the problem logging into my Ubuntu 10.10 via windows RDP into the default Ubuntu RDP service (on port 3389 apparently and tunnels into 5900??). thanks. –  djangofan Jan 13 '11 at 17:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.