Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I dunno what exactly it's called, by cache refresh I mean, refresh the page after clearing its cache. I don't want to clear the entire browser cache.

I prefer Chrome's Dev panel against firebug... don't ask me why. But I can't seem to cache refresh my pages. In Firefox, I know it to be Shift+Refresh.

In Chrome, I've tried Ctrl+R, Ctrl+Refresh, Alt+Refresh, Shift+Refresh but none of them work.

share|improve this question

migrated from stackoverflow.com Dec 9 '10 at 15:49

This question came from our site for professional and enthusiast programmers.

2  
I'm fairly certain a hard refresh is ctrl-f5 just like all the other browsers. –  Joel Potter Sep 7 '09 at 20:50
1  
My version's 4.0.206.1 Tried it again after making a change to my source code (PHP). Refreshed fine in FF with Shift+F5. Change didn't show up Chrome after Ctrl+Refresh. –  gAMBOOKa Sep 7 '09 at 20:54
9  
What about mac version? –  Brian Armstrong May 3 '10 at 21:57
7  
Command-Shift-R works in Mac (OS X 10.6.7 and Chrome 17.0.963.56). –  Joseph Mornin Feb 28 '12 at 14:44
3  
On a mac: hold CONTROL and click Chrome's reload button –  Mitch Fournier May 5 '12 at 19:04

10 Answers 10

up vote 105 down vote accepted

Push F12 then you can right click on refresh and select 'Empty Cache and Hard Reload'

See: http://stackoverflow.com/questions/12633425/chrome-browser-reload-options-new-feature

Edit 02/04/2013 to include everything

The documentation says Ctrl+F5 or Ctrl+Shift+F5

Reloads your current page, ignoring cached content.

Although some have reported this works, others have said it does not work correctly

Your other options are:

1) JavaScript Console

The JavaScript Console is available in two modes within Chrome DevTools: the primary Console tab, or as a split-view you can display while on another tab (such as Elements or Sources).

To open the Console tab, do one of the following:

Use the keyboard shortcut Command - Option - J (Mac) or Control -Shift -J (Windows/Linux). Select View > Developer > JavaScript Console.

F12 doesn't appear to be mentioned here but will open this console as well.

Chrome Developer Tools

Using the JavaScript Console

2) Another interesting option is to open a new incognito window (Ctrl+Shift+N). This window won't use any stored cookies, cached content, or DNS resolutions, so you can test stuff in it without slowing your normal browsing down by dumping the cache. This is what I almost always do instead of clearing the cache.


3) Open Chrome Developer Tools (F12). Click the settings icon (a gear in the bottom right corner). Check "Disable cache". Now when you browse with your Developer tools open caching is disabled.

4) Finally there is also the option of the Click&Clean extension

share|improve this answer
1  
Woah - this is nice! –  gAMBOOKa Nov 30 '12 at 17:20
    
Hidden gem! I wonder if Google advertise these sort of features, they can be a killer with some going to Firefox from Chrome because of it –  CodeBlend Dec 3 '12 at 11:46
1  
Today I learned, awesome. –  Filip Dupanović Dec 19 '12 at 7:36
    
@danhaj how did the above work for you? –  CodeBlend Mar 26 '13 at 15:32
    
This doesn't work for me. f12 does nothing. Chrome 25.0.1364.172 on OSX 10.6.8. –  Jonathan Hartley Mar 29 '13 at 20:19

Another interesting option is to open a new incognito window (Ctrl+Shift+N). This window won't use any stored cookies, cached content, or dns resolutions, so you can test stuff in it without slowing your normal browsing down by dumping the cache. This is what I almost always do instead of clearing the cache.

share|improve this answer
    
+1 I find Chrome will cache file downloads. This is especially frustrating when I'm working on apache/nginx configs and I'm downloading index.php instead of viewing it. The only way is the clear the entire cache, use incognito, or use Firefox. –  James Mar 14 '11 at 16:29
    
+1 nice idea :) –  Danjah Feb 12 '12 at 20:40
1  
argh, except sometimes it doesn't work. I just spent 15 minutes trying to figure out why my externally loaded SWF file wasn't accurate. Firefox showed it as being correct, no keystroke refresh combo in Incognito Chrome cleared the SWF from cache, nor did clearing the actual Chrome cache and refreshing the Incognito window. I had to close and re-open Incognito window completely for the cache to finally let go of the SWF. Was working fine for about an hour until this happened :/ –  Danjah Feb 12 '12 at 22:39
    
Again 5 minutes later, this is not a reliable solution insofar as I can tell. Chrome v17.0.963.46 m –  Danjah Feb 12 '12 at 22:47

According to documentation, Ctrl+F5 or Shift+F5 should work. Maybe you have a proxy configured on IE & chrome, which is caching your page?

share|improve this answer
1  
If you really want to be sure you have to clear the cache using Tools options. –  sorin Jul 22 '10 at 16:17
    
You need to clear the cache using Tools in order to flush the favicon from the cache; normal hard-reload doesn't do it. –  romkyns Dec 22 '10 at 19:03

Chrome's a bitch for this. Sometimes I can get Shift+F5 to work but not always. My solution for the moment is to use the 'Click & Clean' extension. It's ugly but works every time so I'd recommend that for now.

share|improve this answer
    
For me, Ctrl+Shift+R twice works every time. I don't know why they made it so annoying. –  romkyns Sep 8 '11 at 13:46

A workaround is hitting reload very quickly twice in a row.

share|improve this answer
    
Not in all cases it seems, I just had a page that didn't want to load because of earlier dns issues and Chrome simply refused to load it for about a minute... after that it worked again. –  Wolph Sep 20 '13 at 11:51

Open Chrome Developer Tools (F12 or Ctrl+Shift+I or Menu/Tools/Developer Tools). Click the settings icon (a gear in the bottom right corner). Check "Disable cache". Now when you browse with your Developer tools open caching is disabled.

share|improve this answer

I've had problems with Chrome refreshing in spite of using shift+f5 or command+shift+r. What I've found works though pretty brutish is to hold down command+shift+r for a few seconds so that the browser makes multiple attempts to refresh the java cache and fails. Then the next time it successfully retrieve JS from the server.

share|improve this answer
    
Yes, I can confirm this. I've been doing this myself. –  gAMBOOKa Oct 13 '10 at 3:43
    
Agreed...me too. –  Stimul8d Oct 22 '10 at 7:14

Ctrl+Shift+F5 seems to work for me.

share|improve this answer
    
I can't even push buttons like that. –  Eugene Jun 12 '12 at 17:25

it could simply be your keyboard settings, check if you have the functions keys enabled or disabled, with my logitech keybaord it is the FMode key, similar to NumLock!

share|improve this answer
  1. Click the Tools menu. (the wrench in the upper-right corner)

  2. Select Options.

  3. Click the Under the Hood tab.

  4. Click Clear browsing data…

  5. Check the boxes for the types of information you wish to delete.

    • Clear browsing history
    • Clear download history
    • Empty the cache
    • Delete cookies
    • Clear saved passwords

You can also choose the period of time you wish to delete cached information using the Clear data from this period dropdown menu.

  1. Click Clear Browsing Data when ready.
share|improve this answer
10  
Why would I delete my entire cache to test a single page?! I'd rather use Firefox. –  gAMBOOKa Oct 20 '10 at 8:31
    
Chrome is back in the picture as you can now hard reload - superuser.com/a/512833/92862 –  CodeBlend Dec 3 '12 at 11:45

protected by random Dec 30 '10 at 0:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.