Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm sitting in a Hospital with a PC running XP and a macbook. The PC connected to the wifi and got an IP address. The MacBook connected earlier, but now cannot get an IP address. What can I do to debug this? Is it really that the DHCP server isn't giving the MacBook an IP address? Or is there some bug with OS X?

I have tried many diffrent things to get the MacBook to connect with no luck. Now, I just want to understand what is actually happening.

share|improve this question
    
Open the Console and try to track down errors, or manually connnect with the terminal –  Josh B Dec 9 '10 at 19:38
    
I didn't see any errors in the console. It shows that the wifi connects and then after a bit it shows that it is using a self-assigned ip address. Is there a way to interact with DHCP in the terminal to see what it actually returns? –  dtauzell Dec 9 '10 at 21:23
    
What do your Airport preferences look like? Have you tried renewing your DHCP lease? Is there an authentication system (e.g. for billing you) that might prevent multiple devices per user? It would also help if you mentioned what "many different things" are, and their outcome, even if unsuccessful. –  Daniel Beck Dec 10 '10 at 11:23
    
do you have different dns settings on the mac? for some wifi networks, you need to use the default dns settings (no google dns, opendns, etc) before they give you an actual ip. –  yanokwa Jan 1 '11 at 15:40
add comment

1 Answer

Assuming you have Snow Leopard on your Macbook (you can see it in the "Apple" menu -> "About This Mac", should be 10.6.x), you can:

  • Turn off, then on airport, using the icon in the menu bar. See if it connects
  • Open Network Utility, then select Airport card (EN1) and have a look at the IP, connection, etc.

If you can connect with your XP, then for sure you can with your MB. Maybe the access point in the hospital was handling too much connections :-)

share|improve this answer
2  
That is my thought, too, but I'd like a way to see that. I can't find any logs in OS X that say something like "Failed to get IP Address from DHCP" –  dtauzell Dec 9 '10 at 17:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.