Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some trouble installing msysgit 1.7.3.1preview on Windows 7 Home Premium. I downloaded the setup file from the Google Code and then ran it. Upon running, I got the following error:

enter image description here

I have tried downloading and running different older versions of msysgit with no luck. For the record, I have administrative privileges and there are no other user accounts on this Windows machine. Any help would be greatly appreciated. Thanks.

UPDATE: I have managed to semi-fix this problem. I turned on User Account Control back to the default setting and and then ran the setup file as an administrator. I successfully managed to install Git. However, this means I have to keep UAC turned on whenever I want to install a new program (I realised that it persists over all programs; not just Git). So it's quite a nuisance.

If anybody knows how I could keep UAC disabled whilst still being able to install programs without running their setup files as an administrator, I would be eternally grateful.

UPDATE: I have changed the question title to better suit the new situation.

share|improve this question
    
Try running as admin -> right click setup.exe -> Run As Admin. –  Sathya Dec 10 '10 at 1:06
    
Tried doing that, but still no love. –  hasc Dec 10 '10 at 17:22
    
When the error message pops up can you see who the installer is running as using process explorer? If the setup.exe is loader for something like MSI the actual running user might be someone different, like LocalSystem. –  snowdude Feb 9 '12 at 17:30
add comment

2 Answers

Looks like a permissions issue, not a UAC issue. There shouldn't be any permissions problems when creating a file/folder in your own user profile. Can you manually create a file/folder in that path without it requiring elevated access? If not you have ACL issues as mentioned in another comment.

share|improve this answer
    
> Looks like a permissions issue, not a UAC issue. That is what I thought as well, but I strongly suspect that is his own user profile, so it shouldn't be a permissions issue. –  Synetech Jul 13 '12 at 2:11
add comment

Looks like an UAC issue as seen in this other setup trouble (not related to msysgit)

See this post

It can be a issue in the UAC File Virtualization Filter Driver, therefore make sure you’re user account has permission to be able to run applications that need to write to the AppData -> %TEMP% directory.

alt text


If UAC is turned off, and if running the install as Admin changes nothing (because you already are admin), you can also try:

  1. Create a folder name "Temp" under C:\ // This step is important, the folder has to exist.
  2. Right click the Computer in Start menu and select Properties
  3. Click Advanced System Setting
  4. In System Properties windows, click Advanced tab
  5. Click Environment Variables button
  6. Under User variables list, double click TMP
  7. Change Variable value: from "%USERPROFILE%\AppData\Local\Temp" to "C:\Temp"
share|improve this answer
    
Not sure what I'm supposed to do here... I have UAC turned off. –  hasc Dec 9 '10 at 22:05
    
@Aero: did you try to change the TMP variable? I have updated my answer with a link and a process for that. –  VonC Dec 10 '10 at 4:53
    
I've followed the steps, and now I get the same error except the path is C:\Temp and not the previous path. I do appreciate your help, though. I've also only recently upgraded (not a clean install) from Vista to 7 so that may be an issue. –  hasc Dec 10 '10 at 17:23
1  
@Aero: interesting. There is obviously some ACL issue with this migration... –  VonC Dec 10 '10 at 17:47
    
I've managed to partly solve the problem - added details to my question. –  hasc Dec 11 '10 at 16:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.